ACM: 模拟题 poj 2632 (开始做模拟…

                                                                  Crashing Robots

Description

In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.

Input

The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.

ACM: <wbr>模拟题 <wbr>poj <wbr>2632 <wbr>(开始做模拟题,思路很清晰但是题目晦涩.)
Figure 1: The starting positions of the robots in the sample warehouse


Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of

  • L: turn left 90 degrees,
  • R: turn right 90 degrees, or
  • F: move forward one meter,


and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.

Output

Output one line for each test case:

  • Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
  • Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
  • OK, if no crashing occurs.


Only the first crash is to be reported.

Sample Input

4

5 4

2 2

1 1 E

5 4 W

1 F 7

2 F 7

 

5 4

2 4

1 1 E

5 4 W

1 F 3

2 F 1

1 L 1

1 F 3

 

5 4

2 2

1 1 E

5 4 W

1 L 96

1 F 2

 

5 4

2 3

1 1 E

5 4 W

1 F 4

1 L 1

1 F 20

Sample Output

Robot 1 crashes into the wall

Robot 1 crashes into robot 2

OK

Robot 1 crashes into robot 2

题意: 输入每个机器人的坐标的方向,输入ACTION.最后判断机器人们是否碰撞,或则撞墙,或则没事.

解题思路:
                 1. 直接模拟没什么好说的.
                 2. 要注意的是L or R是旋转多次.(一开始以为是走一步转一次).

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 105

int dir[4][2] = { {-1,0} , {0,-1} , {1,0} , {0,1} };
int n, m ;
int N, M ;

struct gridnode
{
    bool visit;
    int number;
}grid[MAX][MAX];

struct node
{
    int x,y;
    int direction;
}robot[MAX];

struct anode
{
    int number;
    int direction;
    int step;
}action[MAX];

void init()
{
    for(int i = 0; i < MAX; ++i)
    {
        for(int j = 0; j < MAX; ++j)
        {
            grid[i][j].visit = false;
            grid[i][j].number = -1;
        }
    }
}

void runAction()
{
    for(int i = 1; i <= M; ++i)
    {
        int t = action[i].number;

        if(action[i].direction == 0)
        {
            for(int j = action[i].step; j > 0; --j)
            {
            
                grid[ robot[t].x ][ robot[t].y ].visit = false;
                grid[ robot[t].x ][ robot[t].y ].number = -1;
            
            //    printf("%d %d %d\n",t,robot[t].x,robot[t].y);
            
                robot[t].x += dir[ robot[t].direction ][0];
                robot[t].y += dir[ robot[t].direction ][1];
            
            
                if(robot[t].x >= 1 && robot[t].x <= n && robot[t].y >= 1 && robot[t].y <= m)
                {
                    if(grid[ robot[t].x ][ robot[t].y ].visit == true )
                    {
                        printf("Robot %d crashes into robot %d\n",t,grid[ robot[t].x ][ robot[t].y ].number);
                        return ;
                    }
                    grid[ robot[t].x ][ robot[t].y ].visit = true;
                    grid[ robot[t].x ][ robot[t].y ].number = t;
                
                }
                else
                {
                    printf("Robot %d crashes into the wall\n",t);
                    return ;
                }
            }
        }
        else
        {
            for(int j = action[i].step; j > 0; --j)
            {
                robot[t].direction += action[i].direction;
                robot[t].direction %= 4;
    
                if(robot[t].direction < 0)
                    robot[t].direction += 4;
            }
        }
    }
    printf("OK\n");
    return ;
}

int main()
{
    freopen("input.txt","r",stdin);
    int caseNum;
    scanf("%d",&caseNum);
//    printf("%d\n",caseNum);
    
    while(caseNum--)
    {
    
    //    printf("%d ",caseNum);
    
        init();
    //    memset(grid,false,sizeof(grid));
        scanf("%d %d",&m,&n);
        scanf("%d %d",&N,&M);
        
        for(int i = 1; i <= N; ++i)
        {
            char dire;
            scanf("%d %d %c",&robot[i].y,&robot[i].x,&dire);
            robot[i].x = (n+1) - robot[i].x;
            if(dire == 'N')
                robot[i].direction = 0;
            else if(dire == 'W')
                robot[i].direction = 1;
            else if(dire == 'S')
                robot[i].direction = 2;
            else if(dire == 'E')
                robot[i].direction = 3;
            grid[ robot[i].x ][ robot[i].y ].visit = true;
            grid[ robot[i].x ][ robot[i].y ].number = i;
        //    printf("%d %d %d\n",robot[i].x,robot[i].y,robot[i].direction);
        }
        
        for(int i = 1; i <= M; ++i)
        {
            char dire;
            scanf("%d %c %d",&action[i].number,&dire,&action[i].step);
            if(dire == 'F')
                action[i].direction = 0;
            else if(dire == 'L')
                action[i].direction = 1;
            else if(dire == 'R')
                action[i].direction = -1;
            
        //    printf("%d %d %d\n",action[i].number,action[i].direction,action[i].step);
        }
        runAction();
    //    cout << endl;
    }
    
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值