ACM: 动态规划 poj 2192

                                                                                                                                          Zipper
Description
Given three strings, you are to determine whether the third string can be formed by combining the characters in the first two strings. The first two strings can be mixed arbitrarily, but each must stay in its original order.

For example, consider forming "tcraete" from "cat" and "tree":

String A: cat
String B: tree
String C: tcraete

As you can see, we can form the third string by alternating characters from the two strings. As a second example, consider forming "catrtee" from "cat" and "tree":

String A: cat
String B: tree
String C: catrtee

Finally, notice that it is impossible to form "cttaree" from "cat" and "tree".

Input

The first line of input contains a single positive integer from 1 through 1000. It represents the number of data sets to follow. The processing for each data set is identical. The data sets appear on the following lines, one data set per line.

For each data set, the line of input consists of three strings, separated by a single space. All strings are composed of upper and lower case letters only. The length of the third string is always the sum of the lengths of the first two strings. The first two strings will have lengths between 1 and 200 characters, inclusive.

Output

For each data set, print:

Data set n: yes

if the third string can be formed from the first two, or

Data set n: no

if it cannot. Of course n should be replaced by the data set number. See the sample output below for an example.

Sample Input

3

cat tree tcraete
cat tree catrtee
cat tree cttaree

Sample Output

Data set 1: yes

Data set 2: yes
Data set 3: no

题意: 给出三个字符串, 第三个要是前面两个序列的合并而成的, 但是字符的顺序要一致.(字符前后关系不变)
     问第三个字符是否符合这个条件.

解题思路:
    1. 一开始想到的是递归匹配 + 记忆化搜索.
    2. 设状态: dp[i][j]: 判断str1字符串中前i个字符和str2字符串前j个字符是否可以组成str3[i+j];
    3. 接着就是记忆化.
    看了网上别人的思路是用递推的思路. 思路没太大的区别. 只是从后往前,还是从前往后的问题.

代码:
// times: 16MS
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 205

char str1[MAX], str2[MAX], str3[MAX*2];
int dp[MAX][MAX];

int solve(int i,int j)
{
    if(dp[i][j] != -1)
        return dp[i][j];
    else
    {
        int k = i+j;
        if(i > 0 && str1[i] == str3[k])
        {
            if(solve(i-1,j))
                return dp[i][j] = 1;
        }
        if(j > 0 && str2[j] == str3[k])
        {
            if(solve(i,j-1))
                return dp[i][j] = 1;
        }
        return dp[i][j] = 0;
    }
}

int main()
{
    int k = 1;
//    freopen("input.txt","r",stdin);
    int caseNum;
    scanf("%d",&caseNum);
    while( caseNum-- )
    {
        scanf("%s %s %s",str1+1,str2+1,str3+1);
        memset(dp,-1,sizeof(dp));
       
        int len1 = strlen(str1+1);
        int len2 = strlen(str2+1);
        dp[0][0] = 1;
        if( solve(len1,len2) )
            printf("Data set %d: yes\n",k++);
        else
            printf("Data set %d: no\n",k++);
           
    }
}


// times: 76MS
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
#define MAX 205

char str1[MAX], str2[MAX], str3[MAX*2];
bool dp[MAX][MAX];

int main()
{
//    freopen("input.txt","r",stdin);
    int caseNum;
    int k = 1;
    scanf("%d",&caseNum);
    while(caseNum--)
    {
        scanf("%s %s %s",str1,str2,str3);
        memset(dp,false,sizeof(dp));
       
        dp[0][0] = true;
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        for(int i = 0; i <= len1; ++i)
        {
            for(int j = i; j <= len2+len1; ++j)
            {
                if(i != 0 && str1[i-1] == str3[j-1])
                    dp[i][j] = dp[i-1][j-1];
                if(j > i && str2[j-i-1] == str3[j-1])
                    dp[i][j] = (dp[i][j-1] || dp[i][j]);
            }
        }
        if(dp[len1][len1+len2])
            printf("Data set %d: yes\n",k++);
        else
            printf("Data set %d: no\n",k++);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值