ACM: 图论题+记忆DP poj 2662 (边…

                                                          A Walk Through the Forest
Description
Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

Input

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N <= 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 <= d <= 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

Output

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647.

Sample Input

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

Sample Output

2
4

题意: 从A到B, 并且B到达终点最短路径小于A到终点的最短路径. 要你求出一共存在多少条B开始的这样的路径.

 

解题思路:

   1. 反过来求出终点到各个点的最短路. (正难则反)

   2. 接着我们要求得时B到达终点并且小于A到终点的路径数目. 满足条件 u --> v, dis[v][t] > dis[i][t]

      (1 <= i <= n)

   3. 采用当然是记忆化搜索.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
#define MAX 1005
const int INF = 2147483647;

struct node
{
 int u,v;
 int w;
 int next;
}edges[MAX*2];

int n, m;
int first[MAX];
bool g[MAX][MAX], vis[MAX];
int dist[MAX];
int dp[MAX];
int num;

void addedge(int u,int v,int w)
{
 edges[num].u = u;
 edges[num].v = v;
 edges[num].w = w;
 edges[num].next = first[u];
 first[u] = num++;
}

void read_graph()
{
 memset(g,false,sizeof(g));
 memset(dp,-1,sizeof(dp));
 memset(first,-1,sizeof(first));
 num = 0;
 int u, v, w;
 for(int i = 0; i < m; ++i)
 {
  scanf("%d %d %d",&u,&v,&w);
  addedge(u,v,w);
  addedge(v,u,w);
  g[u][v] = g[v][u] = true;
 }
}

void spfa(int start)
{
 queue<int> qu;
 memset(vis,false,sizeof(vis));
 qu.push(start);
 vis[start] = true;
 int i;
 for(i = 1; i <= n; ++i) dist[i] = (i == start ? 0 : INF);

 while( !qu.empty() )
 {
  int u = qu.front();
  qu.pop();
  vis[u] = false;

  for(int e = first[u]; e != -1; e = edges[e].next)
  {
   if(dist[edges[e].v] > dist[u] + edges[e].w)
   {
    dist[edges[e].v] = dist[u] + edges[e].w;
    if( !vis[edges[e].v] )
    {
     vis[edges[e].v] = true;
     qu.push(edges[e].v);
    }
   }
  }
 }
}

int solve(int v)
{
 if(dp[v] != -1) return dp[v];
 if(v == 2) return 1;
 dp[v] = 0;
 for(int i = 1; i <= n; ++i)
 {
  if(g[v][i] && dist[v] > dist[i])
  {
   dp[v] += solve(i);
  }
 }
 return dp[v];
}

int main()
{
// freopen("input.txt","r",stdin);
 while(scanf("%d",&n) != EOF && n != 0)
 {
  scanf("%d",&m);
  read_graph();

  spfa(2);
  int result = solve(1);
  printf("%d\n",result);
 }

 return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值