ACM: DP训练好题 动态规划题 poj 1…

Cow Cycling

 

Description

The cow bicycling team consists of N (1 <= N <= 20) cyclists. They wish to determine a race strategy which will get one of them across the finish line as fast as possible.

Like everyone else, cows race bicycles in packs because that's the most efficient way to beat the wind. While travelling at x laps/minute (x is always an integer), the head of the pack expends x*x energy/minute while the rest of pack drafts behind him using only x energy/minute. Switching leaders requires no time though can only happen after an integer number of minutes. Of course, cows can drop out of the race at any time.

The cows have entered a race D (1 <= D <= 100) laps long. Each cow has the same initial energy, E (1 <= E <= 100).

What is the fastest possible finishing time? Only one cow has to cross the line. The finish time is an integer. Overshooting the line during some minute is no different than barely reaching it at the beginning of the next minute (though the cow must have the energy left to cycle the entire minute). N, D, and E are integers.

Input

A single line with three integers: N, E, and D

Output

A single line with the integer that is the fastest possible finishing time for the fastest possible cow. Output 0 if the cows are not strong enough to finish the race.

Sample Input

3 30 20

Sample Output

7

Hint

[as shown in this chart:

                            leader E

               pack  total used this

time  leader  speed   dist   minute

                   25

                    4

      2*         11      16

              13       4

      3*         16       9

              18       4

              20       4

* = leader switch

 

题意: 现在又N头奶牛, 每头奶牛的能量是E, 现在要奶牛们只要有一头完成跑D圈就完成任务.

      但是每次都要由一头奶牛领跑, 没有能量的奶牛可以退场或继续跟跑, 但是带头的奶牛

      体力消耗是: x*x laps/min, 跟跑的是x laps/min. 现在要你计算出最短时间内完成任务.

 

解题思路:

         1. 题意应该很明确, 前n-1头奶牛都领跑过, 第n头奶牛冲线.

         2. 状态: dp[i][j][k]: 表示第i头奶牛领跑, 跑了j圈, 第i头奶牛体力消耗了k的最小时间.

         3. 状态转移方程:

                (1). dp[i][j+p][k+p^2] = min( dp[i][j+p][k+p^2] , dp[i][j][k]+1 );

                (2). dp[i+1][j][j] = min( dp[i+1][j][j] , dp[i][j][k] ) //换一头奶牛领跑不耗时.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
const int INF = (1<<29);

int n, e, d;
int dp[25][105][105];

inline int min(int a,int b)
{
 return a < b ? a : b;
}

int main()
{
 int i, j, k;
// freopen("input.txt","r",stdin);
 while(scanf("%d %d %d",&n,&e,&d) != EOF)
 {
  for(i = 0; i <= n; ++i)
   for(j = 0; j <= d; ++j)
    for(k = 0; k <= e; ++k)
     dp[i][j][k] = INF;
  dp[1][0][0] = 0;
  for(i = 1; i <= n; ++i)
  {
   for(j = 0; j <= d; ++j)
   {
    for(k = 0; k <= e; ++k)
    {
     if(dp[i][j][k] == INF) continue; //无意义
     for(int p = 1; p+j <= d && p*p+k <= e; ++p)
      dp[i][j+p][k+p*p] = min(dp[i][j][k]+1,dp[i][j+p][k+p*p]);
     dp[i+1][j][j] = min(dp[i+1][j][j], dp[i][j][k]);
    }
   }
  }

  int result = INF;
  for(i = 0; i <= e; ++i)
   result = min(result,dp[n][d][i]);
  printf("%d\n",result); //当无法完成任务的时候dp[n][d][0] = 0;
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值