ACM: 数学规律题 数论题 hdoj 1021

 

                  Fibonacci Again

Problem Description
  There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 


Input
  Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 


Output
  Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 


Sample Input
0 1 2 3 4 5
Sample Output
no
no
yes
no
no
no
 
题意: 斐波纳契数 求第n个斐波纳契数是否被3整除.
 
解题思路:
        1. 是否可以被整除. 可以想到: a = a (mod m);
        2. 假设:  a = b (mod m), c = d (mod m);
             ===> a*t1 - b = m*q1,   c*t2 - d = m*q2;
             ===> 两式相加: (a+c)*t - (b+d) = m*q;
             ===> 得: (a+c) = (b+d) (mod m);
        3. 可以得出结论: 只要有一个式子满足即可.
          index: 0   1   2   3   4   5   6   7   8   9   10   11   12   13   14
                 7   11  18  29  47  76  123 199 322 521 843 1364 2207  3571 5778
  a[index]%3==0: n   n   y   n   n   n   y   n   n   n   y    n    n    n    y
          取出可以整除3的下标: 2 6 10 14 ...
        4. 显然: (i-2)%4 == 0 就是可以整除3.
 
代码:
#include <cstdio>
#include <iostream>
#include <cstring>
using namespace std;
 
int n;
int main()
{
// freopen("input.txt","r",stdin);
 while(scanf("%d",&n) != EOF)
 {
  if( (n-2)%4 == 0 )
   printf("yes\n");
  else
   printf("no\n");
 }
 return 0;
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值