ACM: 数学题 uva 11300

F. Spreading the Wealth
Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.
The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.
The Output

For each input, output the minimum number of coins that must be transferred on a single line.
Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4

题意: n个人围一圈, 每个人又a[i]个金币, 现在要用最少的转移金币数量使得每个人得金币相同.

解题思路:
          1. 假设第1个人分配给第n个人得金币是x1, 第二个人分配给第一个人得金币x2, 以此类推.
                原有金币a[i], 即第1个人最终金币数量是a[1]-x1+x2, 设aver为平均值, 得到以下公式:
                a[1]-x1+x2 = aver;
                a[2]-x2+x3 = aver;
                a[3]-x3+x4 = aver;
                    ......
                a[n-1]-xn-1+xn = aver;
                a[n]-xn+x1 = aver;
          2. 那么每个人的变化值是x1,x2,x3,...,xn; 由上面等式可得:
                x1 = x1;
                x2 = x1-(a[1]-aver);
                x3 = x1-( (a[1]-aver)+(a[2]-aver) );
                x4 = x1-( (a[1]-aver)+(a[2]-aver)+(a[3]-aver) );
                      ......
                xn-1 = x1-( (a[1]-aver)+(a[2]-aver)+(a[3]-aver)+...+(a[n-2]-aver) );
                xn = x1-((a[1]-aver)+(a[2]-aver)+(a[3]-aver)+...+(a[n-1]-aver) );
                设上面后缀为Ci; C1 = (a[1]-aver), C2 = ((a[1]-aver)+(a[2]-aver)); 以此类推,得:
                x1 = x1;
                x2 = x1-C1;
                x3 = x1-C2;
                      ......
                xn = x1-Cn-1;
          3. 由上面1,2的推导结果显然是result = min(|x1|+|x1-C1|+|x1-C2|+...+|x1-Cn-1|);
                要使得result结果最小显然只跟x1的选择有关, |x1-Ci|可以看成是x1到Ci的距离(坐标轴上).
                当x1是Ci中位数时, 结果显然是最优解.

代码:
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 1000005

int n;
long long c[MAX], a[MAX];

inline long long my_abs(long long a)
{
      return a < 0 ? (-a) : a;
}

int main()
{
      int i;
//      freopen("input.txt", "r", stdin);
      while(scanf("%d", &n) != EOF)
      {
            long long sum = 0;
            for(i = 1; i <= n; ++i)
            {
                  scanf("%lld", &a[i]);
                  sum += a[i];
            }
            long long aver = sum/n;
            c[0] = 0;
            for(i = 1; i < n; ++i)
                  c[i] = c[i-1]+a[i]-aver;
            sort(c, c+n);
            long long result = 0;
            for(i = 0; i < n; ++i)
                  result += my_abs(c[n/2]-c[i]);
            printf("%lld\n", result);
      }

      return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值