ACM: poj 3141

Distant Galaxy
Description

You are observing a distant galaxy using a telescope above the Astronomy Tower, and you think that a rectangle drawn in that galaxy whose edges are parallel to coordinate axes and contain maximum star systems on its edges has a great deal to do with the mysteries of universe. However you do not have the laptop with you, thus you have written the coordinates of all star systems down on a piece of paper and decide to work out the result later. Can you finish this task?

ACM: <wbr>poj <wbr>3141

Input

There are multiple test cases in the input file. Each test case starts with one integer N, (1 ≤ N ≤ 100), the number of star systems on the telescope. N lines follow, each line consists of two integers: the X and Y coordinates of the Kth planet system. The absolute value of any coordinate is no more than 109, and you can assume that the planets are arbitrarily distributed in the universe.

N = 0 indicates the end of input file and should not be processed by your program.

Output

For each test case, output the maximum value you have found on a single line in the format as indicated in the sample output.

Sample Input

10
2 3
9 2
7 4
3 4
5 7
1 5
10 4
10 6
11 4
4 6
0

Sample Output

Case 1: 7

 

题意: 在坐标上, 给你N个点, 找出一个矩形, 使得这个矩形的边框能框住最多的点, 求出最大个数.

 

解题思路:

      1. 同样枚举每条边的情况, 组合判断那种枚举结果最大, 但是我们需要中间变量来记录我们已经

         计算过的情况, 例如前面枚举的边, 需要用起来, 不用每次都重新计算.(坐标题离散化必须的)

      2. 设leftSide[i]: 第i条竖边左边两条横边的个数, 不包括竖边i上的个数.

           on[i]: 第i条竖边上不包括与横线相交的点的个数.

           on2[i]: 第i条竖边上包括与横线相交的点的个数.

         那么我们枚举y坐标之后, 再枚举2条竖边i,j(i

         leftSide[j]-leftSide[i]+on[i]+on2[j]

         显然, 当我们枚举j边时, 只要满足max(on[i]-leftSide[i])的i竖边即可.

      3. 时间复杂度可以得到: 枚举y坐标的上下界, 加上i,j边, 最后还需要枚举i边; O(n^5);

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 105

int n;
int leftSide[MAX], on[MAX], on2[MAX];
int y[MAX];

struct node
{
 int x, y;
 bool operator <(const node &a) const
 {
  return x < a.x;
 }
}p[MAX];

inline int max(int a, int b)
{
 return a > b ? a : b;
}

int solve()
{
 sort(y, y+n);
 sort(p, p+n);
 int yLine = unique(y, y+n)-y; //删除相同元素
 
 if(yLine <= 2) return n;
 
 int result = 0;
 for(int a = 0; a < yLine; ++a)
 {
  for(int b = a+1; b < yLine; ++b)
  {
   int ymin = y[a], ymax = y[b];
   
   int xLine = 0;
   for(int i = 0; i < n; ++i)
   {
    if(i == 0 || p[i].x != p[i-1].x)
    {
     xLine++;
     on[xLine] = on2[xLine] = 0;
     leftSide[xLine] = leftSide[xLine-1]+on2[xLine-1]-on[xLine-1];
    }
    if(p[i].y > ymin && p[i].y < ymax) on[xLine]++;
    if(p[i].y >= ymin && p[i].y <= ymax) on2[xLine]++;
   }
   
   if(xLine <= 2) return n;
   int temp = 0;
   for(int i = 1; i <= xLine; ++i)
   {
    result = max(result, leftSide[i]+on2[i]+temp);
    temp = max(temp, on[i]-leftSide[i]);
   }
  }
 }
 return result;
}

int main()
{
// freopen("input.txt", "r", stdin);
 int num = 1;
 while(scanf("%d", &n) != EOF)
 {
  if(n == 0) break;
  for(int i = 0; i < n; ++i)
  {
   scanf("%d %d", &p[i].x, &p[i].y);
   y[i] = p[i].y;
  }
  
  int result = solve();
  printf("Case %d: %d\n", num++, result);
 }
 return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值