ACM: uva 1467 - Installations

Installations

In the morning, service engineers in a telecom company receive a list of jobs which they must serve today. They install telephones, internet, ipTVs, etc and repair troubles with established facilities. A client requires a deadline when the requested job must be completed. But the engineers may not complete some jobs within their deadlines because of job overload. For each job, we consider, as a penalty of the engineer, the difference between the deadline and the completion time. It measures how long the job proceeds after its deadline. The problem is to find a schedule minimizing the sum of the penalties of the jobs with the two largest penalties.

A service engineer gets a list of jobs Ji with a serving time si and a deadline di. A job Ji needs time si, and if it is completed at time Ci, then the penalty of Ji is defined to be max{0, Ci di}. For convenience, we assume that the time t when a job can be served is 0 t   and si and di are given positive integers such that 0 < si di. The goal is to find a schedule of jobs minimizing the sum of the penalties of the jobs with the two largest penalties.

For example, there are six jobs Ji with the pair (sidiof the serving time si and the deadline di,i = 1,..., 6, where (s1d1) = (1, 7), (s2d2) = (4, 7), (s3d3) = (2, 4), (s4d4) = (2, 15), (s5,d5) = (3, 5), (s6d6) = (3, 8). Then Figure 1 represents a schedule which minimizes the sum of the penalties of the jobs with the two largest penalties. The sum of the two largest penalties of an optimal schedule is that of the penalties of J2 and J6, namely 6 and 1, respectively, which is equal to 7 in this example.

ACM: <wbr>uva <wbr>1467 <wbr>- <wbr>Installations

 

Figure 1. The optimal schedule of the example

Input 

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given on the first line of the input. The first line of each test case contains an integern 1 n 500), the number of the given jobs. In the next n lines of each test case, the i-th line contains two integer numbers si and di, representing the serving time and the deadline of the job Ji, respectively, where 1 si di 10, 000.

Output 

Your program is to write to standard output. Print exactly one line for each test case. The line contains the sum of the penalties of the jobs with the two largest penalties.

The following shows sample input and ouput for three test cases.

Sample Input 

3

6

1 7

4 7

2 4

2 15

3 5

3 8

7

2 17

2 11

3 4

3 20

1 20

4 7

5 14

10

2 5

2 9

5 10

3 11

3 4

4 21

1 7

2 9

2 11

2 23

Sample Output 

7

0

14

 

题意: 有n个的任务要完成, 给出你它完成需要的时间和deadline, 惩罚值 = max(完成的时刻-deadline, 0);

      需要你计算出最大的惩罚值和次大的惩罚值之和.(每个任务都有一个超时惩罚值)

 

解题思路:

      1. 工作任务分配问题, 很容易想到将deadline小的任务先执行, 任务根据deadline排序.

      2. 如果按照排序后从小到大执行一遍, 可以得出超时任务的最大和次大的惩罚值和它们的编号. 很容易

      想到, 把超时的任务往前掉, 最后就是尝试把超时任务插入哪个位置使得最大和次大的惩罚值之和最小.

 

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 505

struct node
{
 int s, d;
 bool operator <(const node &x) const
 {
  return d < x.d;
 }
}a[MAX];

int n;

inline int max(int a, int b)
{
 return a > b ? a : b;
}

inline int min(int a, int b)
{
 return a < b ? a : b;
}

int solve()
{
 sort(a, a+n);
 int i, j;
 int c1 = 0, c2 = 0, pos = 0;
 int ans, cur = 0;
 for(i = 0; i < n; ++i)
 {
  cur += a[i].s;
  int temp = max(cur-a[i].d, 0);
  if(temp > c1)
  {
   c2 = c1;
   c1 = temp;
   pos = i;
  }
  else if(temp > c2)
  {
   c2 = temp;
   pos = i;
  }
 }

 ans = c1+c2;
 for(i = 0; i < pos; ++i)
 {
  c1 = c2 = cur = 0;
  for(j = 0; j < n; ++j)
  {
   if(i == j) continue;
   cur += a[j].s;
   int temp = max(cur-a[j].d, 0);
   if(temp > c1)
   {
    c2 = c1;
    c1 = temp;
   }
   else if(temp > c2) c2 = temp;

   if(j == pos)
   {
    cur += a[i].s;
    int temp = max(cur-a[i].d, 0);
    if(temp > c1)
    {
     c2 = c1;
     c1 = temp;
    }
    else if(temp > c2) c2 = temp;
   }
  }
  ans = min(ans, c1+c2);
 }
 return ans;
}

int main()
{
// freopen("input.txt", "r", stdin);
 int caseNum;
 scanf("%d", &caseNum);
 while(caseNum--)
 {
  scanf("%d", &n);
  for(int i = 0; i < n; ++i)
   scanf("%d %d", &a[i].s, &a[i].d);

  printf("%d\n", solve());
 }

 return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值