ACM: LA 3266 -&nb…

Tian Ji -- The Horse Racing

Here is a famous story in Chinese history.

That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others.

Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser.

Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian.

Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match.

It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?

 ACM: <wbr>LA <wbr>3266 <wbr>- <wbr>Tian <wbr>Ji <wbr>-- <wbr>The <wbr>Horse <wbr>Racing

 

Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses -- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.

Input 

The input consists of up to 50 test cases. Each case starts with a positive integern n 1000) on the first line, which is the number of horses on each side. The nextn integers on the second line are the speeds of Tian's horses. Then the next nintegers on the third line are the speeds of the king's horses. The input ends with a line that has a single `0' after the last test case.

Output 

For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.

Sample Input 

3

92 83 71

95 87 74

2

20 20

20 20

2

20 19

22 18

0

Sample Output 

200

0

0

 

题意: 经典问题田忌赛马, 如果田忌胜获得200, 平0, 输-200. 计算出田忌最多可以获得多少银子.

 

解题思路:

      1. 一道DP题, 先找出决策, 再列动态方程.

      2. 将2人得马先按照从大到小排序.

      (1)当田忌的当前最强马跟King的当前最强的马, 如果输的话,反正结果都是输, 那不如选择最差的

      马去, 这样就会不浪费, 同时为后面的比赛准备.

      (2)如果是胜利的话, 田忌当前最强的马肯定比King后面的马还要强. 这样当然选择当前最强的马去.

      分析到这里应该可以知道决策有: 选出当前最强的或者是当前最差的马.

      设dp[i][j]: King选出了i匹马, 那么田忌也应该出i匹马, 只是田忌从前面和后面怎么选的问题,

      田忌从前面选择了j匹马的最优值.

      3. 因此, 当前King出的是i号马, 田忌要么选j号马, 要么是n-(i-j)+1号马.

         dp[i][j] = max( dp[i-1][j-1]+判断(j, i), dp[i-1][j]+判断(n-(i-j)+1, i) )

         结果: max(dp[n][i]) (i ∈ 1...n);

代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
#define MAX 1005

int n;
int a[MAX], b[MAX];
int dp[MAX][MAX];

inline int max(int a, int b)
{
 return a > b ? a : b;
}

bool cmp(int a, int b)
{
 return a > b;
}

int judge(int i, int j)
{
 if(a[i] > b[j]) return 1;
 else if(a[i] < b[j]) return -1;
 else return 0;
}

int main()
{
// freopen("input.txt", "r", stdin);
 int i, j;
 while(scanf("%d", &n) != EOF)
 {
  if(n == 0) break;
  for(i = 1; i <= n; ++i)
   scanf("%d", &a[i]);
  for(j = 1; j <= n; ++j)
   scanf("%d", &b[j]);

  sort(a+1, a+n+1, cmp);
  sort(b+1, b+n+1, cmp);
  dp[0][0] = 0;

  for(i = 1; i <= n; ++i)
  {
   dp[i][0] = dp[i-1][0] + judge(n-i+1, i);
   for(j = 1; j < i; ++j)
   {
    dp[i][j] = max(
       dp[i-1][j-1]+judge(j, i),
       dp[i-1][j]+judge( n-(i-j)+1, i )
      );
   }
   dp[i][i] = dp[i-1][i-1]+judge(i,i);
  }

  int ans = dp[n][0];
  for(i = 1; i <= n; ++i)
   ans = max(ans, dp[n][i]);

  printf("%d\n", ans*200);
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值