POJ1850——Code

Code
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 9367 Accepted: 4482

Description

Transmitting and memorizing information is a task that requires different coding systems for the best use of the available space. A well known system is that one where a number is associated to a character sequence. It is considered that the words are made only of small characters of the English alphabet a,b,c, ..., z (26 characters). From all these words we consider only those whose letters are in lexigraphical order (each character is smaller than the next character). 

The coding system works like this: 
• The words are arranged in the increasing order of their length. 
• The words with the same length are arranged in lexicographical order (the order from the dictionary). 
• We codify these words by their numbering, starting with a, as follows: 
a - 1 
b - 2 
... 
z - 26 
ab - 27 
... 
az - 51 
bc - 52 
... 
vwxyz - 83681 
... 

Specify for a given word if it can be codified according to this coding system. For the affirmative case specify its code. 

Input

The only line contains a word. There are some constraints: 
• The word is maximum 10 letters length 
• The English alphabet has 26 characters. 

Output

The output will contain the code of the given word, or 0 if the word can not be codified.

Sample Input

bf

Sample Output

55

Source


题目大意:

已知一个长度不超过10的字符串 st ,编码规则为


以此类推,求所给串 st 所对应的编码

思路:

最终答案为按照字典序比 st 小的个数 加一,

也是一个组合问题,还要用到那个组合转化式子


第一步,先求出长度小于 len 的字符串的个数;

第二步,处理长度为 len 的情况,逐位检测,具体看代码注释


//Source Code

//Memory: 720K		Time: 16MS
//Language: G++		Result: Accepted

#include <iostream>
#include <cstring>

using namespace std;

int c[30][30];

void init()          //储存组合数
{
    for( int i = 0;i <= 26;i++ )
    {
        for( int j = 0;j <= i;j++ )
        {
            if( !j||i==j )
                c[i][j] = 1;
            else
                c[i][j] = c[i-1][j-1] + c[i-1][j];
        }
    }
}

int main()
{
    init();     //初始化

    char st[15];
    while( cin>>st )
    {
        int len = strlen(st);

        int flag = 0;     //标志变量
        for( int i = 0;i < len-1;i++ )       //判断是否合法
            if( st[i+1] <= st[i] )
            {
                cout<<0<<endl;
                flag = 1;
                break;
            }

        if( flag )       //若标志变量改变,说明字符串不合法,此时进行下一组测试
            continue;

        int sum = 0;
        for( int i = 1;i < len;i++ )         //求长度小于 len 的字符串的个数
        {
            sum += c[26][i];
        }

        for( int i = 0;i < len;i++ )       //处理长度为 len 的情况
        {
            char t;
            if( i==0 )
                t = 'a';           //若检测第一个字符,则把 t 赋为 a
            else
                t = st[i-1]+1;     //否则,第 i 个字符至少比前一个要大 一个字符(因为递增)  
            while( t<st[i] )
            {
                sum += c['z'-t][len-i-1];       //从比 前一个字符即 st[i-1] 大的字母中选 len - i -1个
                t++;             //继续检测下一个的情况
            }

        }

        cout<<sum+1<<endl;         //因为 sum 的值为比 st 小的字符串的个数,所以 st 的编码为 sum + 1
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值