Happy 2004

Happy 2004


Problem Description
Consider a positive integer X,and let S be the sum of all positive integer divisors of 2004^X. Your job is to determine S modulo 29 (the rest of the division of S by 29).

Take X = 1 for an example. The positive integer divisors of 2004^1 are 1, 2, 3, 4, 6, 12, 167, 334, 501, 668, 1002 and 2004. Therefore S = 4704 and S modulo 29 is equal to 6.
 

Input
The input consists of several test cases. Each test case contains a line with the integer X (1 <= X <= 10000000). 

A test case of X = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, in a separate line, please output the result of S modulo 29.
 

Sample Input
  
  
1 10000 0
 

Sample Output
  
  
6 10

2004有三个素因子2,3,167,(还可以看做是一个排列组合题目)


如图所示2004的素因子其实也就是2004的x次方的素因子,对于2004的x次方,ans=(2^0+2^1+2^2.......+2^e1)*(3^0+3^1+3^2+.....+3^e2)*(167^0+167^1+167^2+.......+167^e3)

每个小括号里是每个素因子可能形成的组合,乘起来就是所求的结果(理解不了的试着拆开写写),剩下就是合理运用取余,进行等比数列求和(注意这里要用到取模的逆元或者用二分等比数列求和)

#include<stdio.h>
#define M 29
#define LL long long
LL multi(LL a,LL b)
{
	LL res=0;
	while(b)
	{
		if(b&1)
		{
			res=(res+a)%M;
		}
		b>>=1;
		a=(a+a)%M;
	}
	return res;
}
LL pow(LL a,LL b)
{
	LL res=1;
	while(b)
	{
		if(b&1)
		{
			res=multi(res,a);
		}
		b>>=1;
		a=multi(a,a);
	}
	return res;
}
int main()
{
	LL x;
	while(scanf("%lld",&x),x)
	{
		LL div_2,div_3,div_167;
		div_2=(pow(2,2*x+1)-1)%M;
		div_3=(pow(3,x+1)-1)*15%M;
		div_167=(pow(22,x+1)-1)*18%M;
		printf("%lld\n",(div_2*div_3*div_167)%M);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值