团体程序设计天梯赛 玩转二叉树

题意
给定一棵二叉树的中序遍历和前序遍历,请你先将树做个镜面反转,再输出反转后的层序遍历的序列。所谓镜面反转,是指将所有非叶结点的左右孩子对换。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(<=30),是二叉树中结点的个数。第二行给出其中序遍历序列。第三行给出其前序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树反转后的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:
7
1 2 3 4 5 6 7
4 1 3 2 6 5 7
输出样例:
4 6 1 7 5 3 2

代码实现

#include <iostream>
#include<cstdio>
#include<queue>
#include<stdlib.h>
using namespace std;
#define N 36
int pre[N],in[N],aft[N],ans[N];
struct BTNode
{
    int data;
    BTNode *lchild,*rchild;
}*Tree;
queue<BTNode *> qu;
//已知中序遍历和前序遍历输出后序遍历且是镜面的后序遍历
BTNode *createBT(int *pre,int *in ,int n)
{
    int *p,k;
    BTNode *b;
    b=(BTNode *)malloc(sizeof(BTNode));
    if(n<=0)
        return NULL;
    b->data=*pre;
    for(p=in; p<in+n; p++)
        if(*p==*pre)
            break;
    k=p-in;
    b->lchild=createBT(pre+1,in,k);
    b->rchild=createBT(pre+k+1,in+k+1,n-k-1);
    return b;
}
void print_ans()
{
    int countt=0;
    while(!qu.empty()) qu.pop();
    qu.push(Tree);
    while(!qu.empty())
    {
        BTNode *res=qu.front();
        qu.pop();
        ans[countt++]=res->data;
        //此处决定是否是镜面,若镜面先判断右孩子,否则先判断左孩子
        if(res->rchild!=NULL)
        {
            qu.push(res->rchild);
        }
        if(res->lchild!=NULL)
        {
            qu.push(res->lchild);
        }
    }
    for(int i=0; i<countt-1; i++)
    {
        printf("%d ",ans[i]);
    }
    printf("%d\n",ans[countt-1]);

}

+(中序+后序->层序)

#include <iostream>
#include<cstdio>
#include<queue>
#include<stdlib.h>
using namespace std;
#define N 36
int pre[N],in[N],aft[N],ans[N];
struct BTNode
{
    int data;
    BTNode *lchild,*rchild;
}*Tree;
queue<BTNode *> qu;
BTNode *createBT(int *pre,int *aft,int n)
{
    int *p,k;
    BTNode *b;
    if(n<=0) return NULL;
    b=(BTNode *)malloc(sizeof(BTNode));
    b->data=*(aft+n-1);
    for(p=pre;p<pre+n;p++)
        if(*p==*(aft+n-1))
            break;
    k=p-pre;
    b->lchild=createBT(pre,aft,k);
    b->rchild=createBT(pre+k+1,aft+k,n-k-1);
    return b;
}
void print_ans()
{
    int countt=0;
    while(!qu.empty())qu.pop();
    qu.push(Tree);
    BTNode *res;
    while(!qu.empty())
    {
        res=qu.front();
        qu.pop();
        ans[countt++]=res->data;
        if(res->lchild!=NULL)
            qu.push(res->lchild);
        if(res->rchild!=NULL)
            qu.push(res->rchild);
    }
    for(int i=0;i<countt-1;i++)
        printf("%d ",ans[i]);
    printf("%d\n",ans[countt-1]);
}

int main()
{
    int n;
    scanf("%d",&n);
    for(int i=0; i<n; i++)
        scanf("%d",&pre[i]);
    for(int i=0;i<n;i++)
        scanf("%d",&aft[i]);
    Tree=createBT(pre,aft,n);
    print_ans();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值