团体程序设计天梯赛 关于堆的判断

题意
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:

“x is the root”:x是根结点;
“x and y are siblings”:x和y是兄弟结点;
“x is the parent of y”:x是y的父结点;
“x is a child of y”:x是y的一个子结点。
输入格式:

每组测试第1行包含2个正整数N(<= 1000)和M(<= 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[-10000, 10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出“T”,否则输出“F”。

输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T

实现代码

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<math.h>
#include<stdio.h>
using namespace std;
#define N 106
#define eps 1e-6
int num[1100],top=1;
int find_num(int n)
{
    for(int i=1; i<top; i++)
        if(num[i]==n)
            return i;
    return -1;
}
int main()
{
    int n,m;
    char str[105];
    string str2;
    scanf("%d%d",&n,&m);
    for(int i=0; i<n; i++)
    {
        int x,s;
        scanf("%d%*c",&x);
        num[top++]=x;
        s=top-1;
        while(s/2)
        {
            if(num[s/2]>num[s])
                swap(num[s/2],num[s]);
            s/=2;
        }
    }
    while(m--)
    {
        int a,b;
        gets(str);
        str2=(string)str;
        if(str2.find("root")!=str2.npos)
        {
            sscanf(str,"%d",&a);
            printf(num[1]==a?"T\n":"F\n");
        }
        else if(str2.find("siblings")!=str2.npos)
        {
            sscanf(str,"%d%*s%d",&a,&b);
            int fi=find_num(a);
            printf(num[fi^1]==b?"T\n":"F\n");
        }
        else if(str2.find("parent")!=str2.npos)
        {
            sscanf(str,"%d%*s%*s%*s%*s%d",&a,&b);
            int fi=find_num(a);
            printf((num[fi*2]==b||num[fi*2+1]==b)?"T\n":"F\n");
        }
        else if(str2.find("child")!=str2.npos)
        {
            sscanf(str,"%d%*s%*s%*s%*s%d",&a,&b);
            int fi=find_num(b);
            printf((num[fi*2]==a||num[fi*2+1]==a)?"T\n":"F\n");
        }
    }
    return 0;
}

PS:感谢队友的堆排序,还有记到手上的npos,我也很好奇对于以后这是一段怎样的日子。代码原作者出门左拐嗯( ̄。。 ̄)继续加油

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值