POJ 1265 Area(Pick定理、向量积求面积)

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area.
You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself.
Input

The first line contains the number of scenarios.
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs dx,dy of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units.
Output

The output for every scenario begins with a line containing Scenario #i: where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.
Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3
Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0

问题描述
给出一个平面上的简单多边形,求其边界内的点数、边界上的点数以及面积。
注意:输入时是输入的 x 轴与 y 轴方向相距上一个点的距离,需要自己处理数据得到每个点的坐标。

解题思路
该题涉及的知识点主要有三条:
1.求多边形边界点数:以整点为定点的线段覆盖的点数为 gcd(dx,dy),其中 dx , dy 分别代表该条线段在 x 轴方向和 y 轴方向占的点数。该题边缘点数标记为 total。
2.Pick公式:主要是求解整点坐标的多边形面积,且面积 S=a(多边形内部点数)+b(多边形外部点数)/2-1。对于该题,通过本公式可得多边形内部点数=(S-(total/2)+1)。
3.求解多边形面积:对于任意一个多边形面积=按照一定顺序(顺时针or逆时针)求相邻两点与原点组成的向量的叉积之和/2。
(向量积的模表示以两个向量为邻边的平行四边形的面积,三角形面积则/2);
(原理是把多边形剖分成多个三角形,选取的点可在多边形内也可在多边形外,选取原点便于计算)。

代码实现

#include <iostream>
#include<cstdio>
#include<cmath>
#include<stdlib.h>
#include<cstring>
using namespace std;
#define maxn 107
struct node
{
    int x;
    int y;
}point[maxn];
int gcd(int a,int b)
{
    if(b==0)
        return a;
    else
        return gcd(b,a%b);
}
double getArea(node a,node b)
{
    return a.x*b.y-a.y*b.x;
}

int main()
{
    int T,n;
    double area;
    int total,dx,dy;
    scanf("%d",&T);
    for(int num=1;num<=T;num++)
    {
        scanf("%d",&n);
        area=0,total=0;
        point[0].x=0,point[0].y=0;
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&point[i].x,&point[i].y);
            dx=abs(point[i].x);
            dy=abs(point[i].y);
            total+=gcd(dx,dy);
            point[i].x+=point[i-1].x;
            point[i].y+=point[i-1].y;
            area+=getArea(point[i],point[i-1]);
        }
        if(area<0)
            area=-area;
        printf("Scenario #%d:\n",num);
        printf("%d %d %.1f\n\n",(int)(area/2-total/2+1),total,area/2);
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值