POJ 1681 Painter's Problem(高斯消元)

38 篇文章 0 订阅

Description

There is a square wall which is made of n*n small square bricks. Some bricks are white while some bricks are yellow. Bob is a painter and he wants to paint all the bricks yellow. But there is something wrong with Bob’s brush. Once he uses this brush to paint brick (i, j), the bricks at (i, j), (i-1, j), (i+1, j), (i, j-1) and (i, j+1) all change their color. Your task is to find the minimum number of bricks Bob should paint in order to make all the bricks yellow.

Input

The first line contains a single integer t (1 <= t <= 20) that indicates the number of test cases. Then follow the t cases. Each test case begins with a line contains an integer n (1 <= n <= 15), representing the size of wall. The next n lines represent the original wall. Each line contains n characters. The j-th character of the i-th line figures out the color of brick at position (i, j). We use a ‘w’ to express a white brick while a ‘y’ to express a yellow brick.

Output

For each case, output a line contains the minimum number of bricks Bob should paint. If Bob can’t paint all the bricks yellow, print ‘inf’.

Sample Input

2
3
yyy
yyy
yyy
5
wwwww
wwwww
wwwww
wwwww
wwwww

Sample Output

0
15

题目简述

与POJ1222基本一样,这个题是将所有的墙块粉刷成黄色,最后输出需要粉刷的块数,即结果数组ans中等于 1 的数目。
POJ 1222详解

代码实现
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define maxn 20*20
int a[maxn][maxn],length,row,result;
int ans[maxn];
char str[maxn];
int Gauss()
{
    int i, j, k, r,col;
    col=0;
    for(k=0; k<length&&col<length; k++,col++)
    {
        i = k;
        while(i<length && a[i][col]==0)  i++;
        if(i > k)
        {
            for(r=col; r<=length; r++)
                swap(a[i][r], a[k][r]);
        }
        if(a[k][col]==0)
        {
            k--;
            continue;
        }
        for(i=k+1; i<length; i++)
        {
            if(a[i][k])
            {
                for(j=0; j<=length; j++)
                    a[i][j] ^= a[k][j];
            }
        }
    }
    for(i=k; i<length; i++)
        if(a[i][col]!=0) return -1;
    for(i=length-1; i>=0; i--)
    {
        ans[i]=a[i][length];
        for(j=i+1; j<length; j++)
            ans[i]^=(a[i][j]&&ans[j]);
    }
    return 1;
}
int main()
{
    int i,j,T,d;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%*c",&d);
        length=d*d;
        row=d;
        memset(a, 0, sizeof(a));
        for(i=0; i<d; i++)
        {
            scanf("%s%*c",str);
            for(j=0; j<d; j++)
            {
                if(str[j]=='y')
                    a[i*d+j][length]=0;
                else
                    a[i*d+j][length]=1;
                ans[i*d+j]=0;
            }
        }
        for(i=0; i<length; i++)
        {
            int n = i / row;
            int m = i % row;
            for(j=0; j<length; j++)
            {
                int x = j / row;
                int y = j % row;
                if(fabs(x - n) + fabs(y - m) <= 1)
                    a[i][j] = 1;
                else
                    a[i][j] = 0;
            }
        }
        if(Gauss()==-1)
        {
            printf("inf\n");
        }
        else
        {
            result=0;
            for(i=0; i<length; i++)
            {
                if(ans[i])
                    result++;
            }
            printf("%d\n",result);
        }
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值