POJ 2923 Relocation(状压DP+01背包)

Description

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

At their old place, they will put furniture on both cars.
Then, they will drive to their new place with the two cars and carry the furniture upstairs.
Finally, everybody will return to their old place and the process continues until everything is moved to the new place.
Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers n, C1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

题目大意

有n个重量为w的家具,有两辆承重分别为c1,c2的车,问搬完这些家具至少需要多少次搬运。

解题思路

将n个家具分组捆绑,用1,0表示当前状态是否选择这个家具,进行状态压缩;
那么总的捆绑方法数即总状态数就是 (1<<n) ,用mark[]标记其中可以用c1,c2两辆车一次运走的捆绑状态;
在mark[]中选取互相独立(不含有相同的家具)的捆绑状态进行01背包,每一个捆绑状态 i 就相当于一个物品,其体积为mark[i],价值相当于1(对最后运输次数的贡献值为1),dp[i]表示搬运状态 i 所需的最小次数,那么将全部家具都运走的最小次数即为 dp[(1<<n)1]
状态转移方程: dp[j|mark[i]]=min(dp[j|mark[i]],dp[j]+1) ,j与mark[]两个状态满足相互独立。

代码实现

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 1107
#define maxm 107
const int INF=0x3f3f3f3f;
int dp[maxn],mark[maxn];
int w[maxm];
int n,c1,c2;
bool vis[maxn];
bool judge(int x)
{
    int sum=0;
    memset(vis,0,sizeof(vis));  //标记i是否可以用c1一次运走
    vis[0]=1;
    for(int i=0;i<n;i++)  //枚举每个家具
    {
        if(x&(1<<i))  //这个家具被捆绑在当前状态中
        {
            sum+=w[i];  //标记当前状态所含家具的总重量
            for(int j=c1-w[i];j>=0;j--)
                if(vis[j]) //若j可以用c1一次运走,那么j+w[i]也可以
                    vis[j+w[i]]=1;
        }
    }
    for(int i=c1;i>=0;i--)
        if(vis[i]&&sum-i<=c2) return true;  //当前状态可以用两辆车一次运走
    return false;
}
int main()
{
    int T;
    scanf("%d",&T);
    for(int cas=1;cas<=T;cas++)
    {
        memset(dp,INF,sizeof(dp));
        scanf("%d %d %d",&n,&c1,&c2);
        if(c1<c2) swap(c1,c2);
        for(int i=0;i<n;i++)
            scanf("%d",&w[i]);
        int t=0;
        for(int i=1;i<(1<<n);i++)   //遍历每种捆绑的状态
            if(judge(i))     //判断当前状态是否可以一次运走
               mark[++t]=i;  //对一次可以运走的状态进行标记
        dp[0]=0;
        for(int i=1;i<=t;i++)   //枚举可以一次运走的状态
        {
            for(int j=(1<<n)-1;j>=0;j--)   //枚举捆绑的所有状态
            {
                if(dp[j]==INF) continue;
                if((j&mark[i])==0)   //两个状态相互独立,即不含有相同的家具
                    dp[j|mark[i]]=min(dp[j|mark[i]],dp[j]+1);
            }
        }
        printf("Scenario #%d:\n",cas);
        printf("%d\n\n",dp[(1<<n)-1]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值