FZU 2214 Knapsack problem(0-1背包转化)

Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

Input

The first line contains the integer T indicating to the number of test cases.
For each test case, the first line contains the integers n and B.
Following n lines provide the information of each item.
The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.
1 <= number of test cases <= 100
1 <= n <= 500
1 <= B, w[i] <= 1000000000
1 <= v[1]+v[2]+…+v[n] <= 5000
All the inputs are integers.

Output

For each test case, output the maximum value.

Sample Input

1
5 15
12 4
2 2
1 1
4 10
1 2

Sample Output

15

题目大意

有n 个物品,已知每件物品的重量和价值,现在在总重量小于等于B的前提下求可能的最大的价值。

解题思路

由于物品重量太大,所以转化为在同样的价值下求最轻的重量,即dp[i]表示所装物品价值为i 时的最小重量。

代码实现

#include<iostream>
#include<cstring>
using namespace std;
#define IO ios::sync_with_stdio(false);\
cin.tie(0);\
cout.tie(0);
typedef long long ll;
#define maxn 507
#define INF 0x3f3f3f3f
int w[maxn],p[maxn];
int dp[5007];
int main()
{
    IO;
    int T;
    cin>>T;
    while(T--)
    {
        int n,t;
        cin>>n>>t;
        int sum=0;
        memset(dp,INF,sizeof(dp));
        dp[0]=0;
        for(int i=1; i<=n; i++)
        {
            cin>>w[i]>>p[i];
            sum+=p[i];
        }
        for(int i=1; i<=n; i++)
        {
            for(int j=sum; j>=p[i]; j--)
            {
                dp[j]=min(dp[j],dp[j-p[i]]+w[i]);
            }
        }
        int ans=0;
        for(int i=sum;i>0;i--)
            if(dp[i]!=INF&&dp[i]<=t)
            ans=max(ans,i);
        cout<<ans<<endl;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值