Now, here is a fuction:
F(x) = 6 * x7+8*x6+7x3+5*x2-yx (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)
Output
Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.
Sample Input
2
100
200
Sample Output
-74.4291
-178.8534
题意描述:
给一个含有y的表达式f(x),问0 <= x <=100时,x为何值时f(x)取得最小值?
解题思路:
已知在定义域内(x)为凹函数,当倒数为0时取的最小值,因此这道题变成了找出导数为0的二点,利用二分的方法,从两边依次往中间找到另f(x)·为0的点。
Accept Cod:
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const double eps=1e-8;
double y;
double daoshu(double x)
{
return 42*pow(x,6)+48*pow(x,5)+21*pow(x,2)+10*x-y;
}
double ans(double x)
{
return 6*pow(x,7)+8*pow(x,6)+7*pow(x,3)+5*pow(x,2)-y*x;
}
int main()
{
int T;
double mid;
scanf("%d", &T);
while(T--)
{
scanf("%lf", &y);
double l=0,r=100;
while(r-l>eps)
{
mid=(l+r)/2;
if(daoshu(mid)<eps)
l=mid+eps;
else r=mid-eps;
}
printf("%.4f\n", ans(l));
}
return 0;
}