题解-equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y;

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;<br>Now please try your lucky.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
 
 
2 100 -4

Sample Output
 
 
1.6152 No solution!

解题思路:

由方程可知这是一个单调递增的函数(未知数前的系数全部为正数),给定y,求x;

因为方程单调,采用二分法(类似于高中所学的求零点,只不过要求的值为y而不是0);

ps(注意):

1- 方程所求的x是有范围的,所以可以直接用边界试,在边界外,直接说:“木有答案呀”,就不用多做运算了;

AC.1:

#include<bits/stdc++.h>
using namespace std;
double f(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}
double dao(int y,double l,double h)
{
    //cout<<"y="<<y<<"  l="<<l<<"  h="<<h<<endl;
    double mid=(l+h)/2;
    if(h-l>=10e-7)
    {
        //cout<<"h-l="<<h-l<<"  mid="<<mid<<"  f(mid)="<<f(mid)<<endl;
        if(f(mid)==y)
        {
            return mid;
        }
        if(f(mid)>y)
            return dao(y,l,mid);
        if(f(mid)<y)
            return dao(y,mid,h);
    }
    return mid;
}
int main()
{
    int n,y;
    cin>>n;
    while(n--)
    {
        cin>>y;
        if(y<f(0)||y>f(100))
            cout<<"No solution!"<<endl;
        else
        {   printf("%0.4lf\n",dao(y,0,100));
            //cout<<dao(y,0,100);
        }
    }
    return 0;
}
and..英语对我有深深的恶意,,我会待他如初恋的。。
  • 3
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值