LightOJ 1030 Discovering Gold

参看资料:

https://blog.csdn.net/chenzhenyu123456/article/details/49760689

https://blog.csdn.net/yopilipala/article/details/78997211


题目:

You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input

3

1

101

2

10 3

3

3 6 9

Sample Output

Case 1: 101.0000000000

Case 2: 13.000

Case 3: 15

题目大意: 

       有一个1*N的格子,每个格子都有相应的金币数,走到相应格子将得到该格子的金币。 
       从第一个格子出发,每次掷1-6的骰子,根据掷出的值前进。若当前位置 + 掷出的值 > n,则重新掷骰子,到达第n个格子游戏结束。求游戏结束时得到金币的期望。

解题思路:

       设dp[i]为到达i个格子获得gold值的期望,则有dp[ i ] = (dp[ i+1 ] / 6 + ... + dp[ i+6 ] / 6) + dp[ i ]。
       初始化dp[i] = 第i个格子的gold值。

       考的就是一个期望dp ,求期望一个很重要的就是逆求期望,为啥是逆求呢,如果正求是在前面期望的基础之上求期望。期望的期望只是一种可能性,并不符合概率要求。这个可以参考贝叶斯公式的定义,里面说的很清楚。关于求期望,要从已知推到未知,就这个题来说,已知只能是必定到达最后一个格子。所以要从已知走向位置就是逆着求的。

实现代码:

#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
using namespace std;
int gcd(int a,int b){
    return b==0?a:gcd(b,a%b);
}
double dp[110],num[110];

int main(){
    int t,cas=1;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        //初始化
        for(int i=0;i<n;i++){
            scanf("%lf",&num[i]);
            dp[i]=num[i];
        }

        for(int i=n-2;i>=0;i--){
            int choose=min(6,n-i-1);//最远可以向后走几步
            for(int j=1;j<=choose;j++)
                dp[i]+=dp[i+j]/(double)choose;
        }
        printf("Case %d: %.7lf\n", cas++,dp[0]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值