HDU 5929 Basic Data Structure (找规律)

Basic Data Structure

Time Limit: 7000/3500 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 639    Accepted Submission(s): 179


Problem Description
Mr. Frog learned a basic data structure recently, which is called stack.There are some basic operations of stack:

PUSH x: put x on the top of the stack, x must be 0 or 1.
POP: throw the element which is on the top of the stack.

Since it is too simple for Mr. Frog, a famous mathematician who can prove "Five points coexist with a circle" easily, he comes up with some exciting operations:

REVERSE: Just reverse the stack, the bottom element becomes the top element of the stack, and the element just above the bottom element becomes the element just below the top elements... and so on.
QUERY: Print the value which is obtained with such way: Take the element from top to bottom, then do NAND operation one by one from left to right, i.e. If   atop,atop1,,a1 is corresponding to the element of the Stack from top to the bottom, value=atop nand atop1 nand ... nand a1 . Note that the Stack will not change after QUERY operation. Specially, if the Stack is empty now,you need to print ” Invalid.”(without quotes).

By the way, NAND is a basic binary operation:

0 nand 0 = 1
0 nand 1 = 1
1 nand 0 = 1
1 nand 1 = 0

Because Mr. Frog needs to do some tiny contributions now, you should help him finish this data structure: print the answer to each QUERY, or tell him that is invalid.
 

Input
The first line contains only one integer T ( T20 ), which indicates the number of test cases.

For each test case, the first line contains only one integers N ( 2N200000 ), indicating the number of operations.

In the following N lines, the i-th line contains one of these operations below:

PUSH x (x must be 0 or 1)
POP
REVERSE
QUERY

It is guaranteed that the current stack will not be empty while doing POP operation.
 

Output
For each test case, first output one line "Case #x:w, where x is the case number (starting from 1). Then several lines follow,  i-th line contains an integer indicating the answer to the i-th QUERY operation. Specially, if the i-th QUERY is invalid, just print " Invalid."(without quotes). (Please see the sample for more details.)
 

Sample Input
  
  
2 8 PUSH 1 QUERY PUSH 0 REVERSE QUERY POP POP QUERY 3 PUSH 0 REVERSE QUERY
 

Sample Output
  
  
Case #1: 1 1 Invalid. Case #2: 0
Hint
In the first sample: during the first query, the stack contains only one element 1, so the answer is 1. then in the second query, the stack contains 0, l (from bottom to top), so the answer to the second is also 1. In the third query, there is no element in the stack, so you should output Invalid.
 

Source

题意:模拟一个栈的操作,可以PUSH0或1,REVERSE命令意为将栈反转,每次QUERY需要输出栈内数字连续与非的结果。
思路:哈哈哈这道题打重现赛的时候思路是我想出来的,虽然没有想全,但还是觉得自己是个天才。可以发现0与非0或1结果都为1,所以直接找到最后一个0的位置,再判断下面的1是奇数个还是偶数个即可解决。需要注意当最后一个0上面没有数字的时候结果是反着的。实现的时候采用数组进行操作,对栈数组的操作很机智的采用了头尾指针相对位置的处理,但是对0数组的操作就一直在纠结0的固定位置,本来想每次REVERSE的时候都更新一遍0的位置,后来发现会T,于是看了zy的代码,发现自己蠢爆了。之后又各种WA,怎么改怎么WA,后来发现是因为忘了打“Case #1:”那句话..

#include <iostream>
#include <string.h>
#include <algorithm>
#include <math.h>
using namespace std;
#define N 200000
int p[2*N+5];
int d[2*N+5];

int main(){
	
	int t;
	scanf("%d",&t);
	for(int cas=1;cas<=t;cas++){
		int flag=1;
		int l=N,r=N,zl=N,zr=N;
		int n;
		memset(p,0,sizeof(p));
		memset(d,0,sizeof(d));
		scanf("%d",&n);
		printf("Case #%d:\n",cas);
		while(n--){
			char c[20];
			scanf("%s",c);
			if(strcmp(c,"PUSH")==0){
				int x;
				scanf("%d",&x);	
				p[r]=x;
				r+=flag;
				if(x==0){
					d[zr]=r;
					zr+=flag;
				}
			}
			else if(strcmp(c,"POP")==0){
				r-=flag;
				if(p[r]==0){
					zr-=flag;
				}
			}
			else if(strcmp(c,"REVERSE")==0){
				int nl=r-flag;
				int nr=l-flag;
				r=nr;
				l=nl;
				nl=zr-flag;
				nr=zl-flag;
				zr=nr;
				zl=nl;
				flag=-flag;
			} 
			else if(strcmp(c,"QUERY")==0){
			 	if(r==l){
			 		printf("Invalid.\n");
			 		continue;
				}
				if(zr==zl){
					int pos=flag*(r-l);
				 	if(pos%2==0)
				 		printf("0\n");
				 	else
				 		printf("1\n");
				 }
				 else if(zr-flag==zl&&p[r-flag]==0){
				 	int pos=flag*(r-l);
				 	if(pos%2==1)
				 		printf("0\n");
				 	else
				 		printf("1\n");
				 }
				 else{
				 	int pos=d[zl];
				 	if(flag*(pos-l)%2==0)
				 		printf("0\n");
				 	else
				 		printf("1\n");
				 }
			} 
		}
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值