HDU 5533 Dancing Stars on Me(数学+水题)

70 篇文章 0 订阅

Dancing Stars on Me

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1302    Accepted Submission(s): 730


Problem Description
The sky was brushed clean by the wind and the stars were cold in a black sky. What a wonderful night. You observed that, sometimes the stars can form a regular polygon in the sky if we connect them properly. You want to record these moments by your smart camera. Of course, you cannot stay awake all night for capturing. So you decide to write a program running on the smart camera to check whether the stars can form a regular polygon and capture these moments automatically.

Formally, a regular polygon is a convex polygon whose angles are all equal and all its sides have the same length. The area of a regular polygon must be nonzero. We say the stars can form a regular polygon if they are exactly the vertices of some regular polygon. To simplify the problem, we project the sky to a two-dimensional plane here, and you just need to check whether the stars can form a regular polygon in this plane.
 

Input
The first line contains a integer T indicating the total number of test cases. Each test case begins with an integer n , denoting the number of stars in the sky. Following n lines, each contains 2 integers xi,yi , describe the coordinates of n stars.

1T300
3n100
10000xi,yi10000
All coordinates are distinct.
 

Output
For each test case, please output "`YES`" if the stars can form a regular polygon. Otherwise, output "`NO`" (both without quotes).
 

Sample Input
  
  
3 3 0 0 1 1 1 0 4 0 0 0 1 1 0 1 1 5 0 0 0 1 0 2 2 2 2 0
 

Sample Output
  
  
NO YES NO
 
题意:给定n个点坐标(x,y),问这几个点是否能恰好组成正n边形。
思路:感觉董小姐的思路真是碉堡了。直接算均值(x,y)则为正n边形的圆心,然后求其它点到该圆心距离是否相等,主要注意精度问题。
#include <iostream>
#include <algorithm>
#include <string.h>
#include <stdio.h>
#include <math.h>
using namespace std;

int main(){
    
    int t;
    scanf("%d",&t);
    while(t--){
        int n;
        scanf("%d",&n);
        int x[105];
        int y[105];
        double rx=0;
        double ry=0;
        for(int i=0;i<n;i++){
            scanf("%d %d",&x[i],&y[i]);
            rx+=x[i];
            ry+=y[i];
        }
        rx=rx/(1.0*n);
        ry=ry/(1.0*n);
        int flag=0;
        double dis=(x[0]*1.0-rx)*(x[0]*1.0-rx)+(y[0]*1.0-ry)*(y[0]*1.0-ry);
        //cout<<"dis"<<dis<<endl;
        for(int i=1;i<n;i++){
            double dis1=(x[i]*1.0-rx)*(x[i]*1.0-rx)+(y[i]*1.0-ry)*(y[i]*1.0-ry);
        //    cout<<"dis1"<<dis1<<endl;
            if(fabs(dis-dis1)>1e-5){
                flag=1;
                break;
            }
        }
        if(flag)
            cout<<"NO"<<endl;
        else
            cout<<"YES"<<endl; 
    } 
    return 0;
} 



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值