HDU 5974 A Simple Math Problem (数学)

A Simple Math Problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 86    Accepted Submission(s): 49


Problem Description
Given two positive integers a and b,find suitable X and Y to meet the conditions:
                                                        X+Y=a
                                              Least Common Multiple (X, Y) =b
 

Input
Input includes multiple sets of test data.Each test data occupies one line,including two positive integers a(1≤a≤2*10^4),b(1≤b≤10^9),and their meanings are shown in the description.Contains most of the 12W test cases.
 

Output
For each set of input data,output a line of two integers,representing X, Y.If you cannot find such X and Y,output one line of "No Solution"(without quotation).
 

Sample Input
  
  
6 8 798 10780
 

Sample Output
  
  
No Solution 308 490
 

Source

题意:两个整数x,y满足x+y=a,lcm(x,y)=b,问两个数是多少。
思路:一开始只能想到暴力枚举,果不其然的T了。然后就陷入了对数学的无限纠结中,怎么想都想不到如何化简,最后在大佬们的指导下终于会了,其实主要就是没想到gcd(a,b)=c这个关键地方,同时也知道了一条性质:如果x与y互质,那么xy和x+y肯定互质。中间判断是否有解的时候要注意想到所有情况。

#include <iostream>
#include <string.h>
#include <algorithm>
#include <stdio.h>
#include <math.h>
using namespace std;

int gcd(int a,int b){
	return b==0?a:gcd(b,a%b);
}

int main(){
	int a,b;
	while(~scanf("%d %d",&a,&b)){
		int c=gcd(a,b);
		a=a/c;
		b=b/c;
		int g=a*a-4*b;
		if(g<0)
			puts("No Solution");
		else{
			int g2=sqrt(g);
			if(g2*g2!=g)
				puts("No Solution");
			else{
				if((a-g2)%2!=0||(a+g2)%2!=0)
					puts("No Solution");
				else{
					int ans1=(a-g2)/2*c;
					int ans2=(a+g2)/2*c;
					if(ans1>0&&ans2>0){
						if(ans1>ans2){
							int temp=ans1;
							ans1=ans2;
							ans2=temp;
						}
						printf("%d %d\n",ans1,ans2);	
					}
				}
			}
		}
	}
	return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值