HDU 1856 More is better(并查集)

70 篇文章 0 订阅

More is better

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others)
Total Submission(s): 25387    Accepted Submission(s): 9107


Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
 

Author
lxlcrystal@TJU
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1102  1198  1162  1301  1811 

题意: A和B是朋友,B和C是朋友则A和C也是朋友,依次类推,题目的意思就是求最大的朋友圈,即求最大集合中元素的个数。(网上直接复制过来的..)
思路:并查集,但是每次合并节点的时候也需要把节点的权值加到父节点上。还要注意特判当n=0的时候直接输出1。

#include <iostream>
#include <algorithm>
#include <math.h>
#include <stdio.h>
#include <string.h>
using namespace std;
#define MAXN 10000005

int f[MAXN];
int ans[MAXN];

void init(){
    for(int i=0;i<=10000000;i++){
        f[i]=i;
        ans[i]=1;
    }
}

int getf(int v){
    if(f[v]==v)
        return v;
    else{
        f[v]=getf(f[v]);
        return f[v];
    }
}

void merge(int v,int u){
    int t1=getf(v);
    int t2=getf(u);
    if(t1!=t2){
        f[t2]=t1;
        ans[t1]+=ans[t2];
    }
}

int main(){
    
    int n;
    while(~scanf("%d",&n)){
        init();
        int maxn=0;
        for(int i=0;i<n;i++){
            int a,b;
            scanf("%d %d",&a,&b);
            if(maxn<a)
                maxn=a;
            if(maxn<b)
                maxn=b;
            merge(a,b);
        }
        if(n==0)
            puts("1");
        else{
            int maxx=-1; 
            for(int i=0;i<=maxn;i++){
                if(maxx<ans[i])
                    maxx=ans[i]; 
            } 
            printf("%d\n",maxx); 
        }
    }
    return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值