C - Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers:  N and  K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

/*
	队列  step 
	分三个方向搜索  +1  -1  *2 
	种子点入队		开始bfs		符合条件入队  
	队首遍历之后出队    
	
	遍历结束条件;  遇到结束位置 
*/

#include<iostream>
#include<queue>
#include<cstdio>
#include<string.h>
using namespace std;
#define max 1000000

int map[max+10];
int N,K;
struct code{
	int x;		//当前位置 
	int step;	//走到该位置经历的步数
};

bool chack(int x){
	if(x<0||x>=max||map[x])
		return 0;
	return 1;		
}

int Bfs(int x,int y){
	code pos,next;
	pos.x=x;
	pos.step=0;
	map[x]=1;
	queue <code> q;
	q.push(pos);
	while(!q.empty()){
		//准备遍历队首 
		pos=q.front();
		q.pop();
		if(pos.x==K)
			return pos.step;
		//遍历队首右边并入队 
		next.x=pos.x+1;		
		if(chack(next.x)){
			map[next.x]=1;
			next.step=pos.step+1;
			q.push(next);
		}
			
			
		//遍历队首左边并入队
		next.x=pos.x-1;
		if(chack(next.x)){
			map[next.x]=1;
			next.step=pos.step+1;
			q.push(next);
		}
		//遍历队首*2并入队
		next.x=pos.x*2;
		if(chack(next.x)){
			map[next.x]=1;
			next.step=pos.step+1;
			q.push(next);
		}
	}
	return -1;
}
int main(){	
	while(~scanf("%d%d",&N,&K)){
		memset(map,0,sizeof(map));
		cout<<Bfs(N,K)<<endl;
	}		
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值