搜索---广搜---C - Catch That Cow

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K
Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17
Sample Output
4
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue> 
using namespace std;
int step[110];
int v[110];
queue<int>p;
int n,k;
int bfs(int n,int k)
{
	int first,next;
	step[n]=0;
	v[n]=1;
	p.push(n);
	while(!p.empty()) 
	{
		first=p.front();
		p.pop();
		for(int i=0;i<3;i++)
		{
			if(i==0)  next=first-1;
			else if(i==1) next=first+1;
			else  next=first*2;
		//	cout<<"i="<<i<<",next="<<next<<endl;广搜,一层层找就是了,无非就三种规则,一种是时间-1一种是时间+1,一种是时间*2. 
			if(next>110||next<0)  continue;
		    if(!v[next])
		    {
		    	v[next]=1;
		    	p.push(next);
		    	step[next]=step[first]+1;
			}
			if(next==k)
			   return step[next];
		}
	}
	
}
int main()
{
	memset(v,0,sizeof(v));
	scanf("%d%d",&n,&k);
	if(n>=k)
		printf("%d\n",n-k);
    else
	  printf("%d\n",bfs(n,k));
	return 0;
}

注意:

   1.该题目为什么是广度搜索,因为是在求最优解,所以肯定不能用深度搜索,不然一定会超时。

  2.问题分类: 

     2.1考虑问题一定要全面,一种是n>k的,当n大于k的时候,一定不可以再乘以2了(越乘越大,你的牛不就更远了吗?哈哈)

   2.2n<k的时候,无非就是题目中给的那三种情况。一种是+1,一种是-1,另外一种是*2。根据这三种广度搜索就好了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值