C - Catch That Cow POJ3278


C - Catch That Cow
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 3278

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

#include<iostream>
#include<cstring>
#include<string>
#include<cmath>
#include<map>
#include<queue>
#include<cstdio>
#include<vector>
#include<algorithm>
#define bug printf("-----\n");
using namespace std;
const int maxn=100011;
const int inf=210000;
typedef long long ll;
int d[maxn];
bool vis[maxn];
//从当前的X出发,可以到达X+1,X-1,X*2,三个位置处,明显X-1不能成为负数,x+1 也不能大于K,如果大于了就会增加步数,
//但是对于X*2这个条件,可以在保证X<K的情况下,计算X*2的值,而不是保证X*2的值小于K
 void bfs(int x,int k)
{
    queue<int> q;
    memset(vis,false,sizeof(vis));
    memset(d,0,sizeof(d));
    q.push(x);
    vis[x]=true;
    d[x]=0;
    while(!q.empty())
    {
        int x=q.front();
        q.pop();
        if(x==k)return ;
        if(x-1>=0&&!vis[x-1])
        {
            vis[x-1]=true;
            q.push(x-1);
            d[x-1]=d[x]+1;
        }
        if(x+1<=k&&!vis[x+1])
        {
            vis[x+1]=true;
            q.push(x+1);
            d[x+1]=d[x]+1;
        }

        if(x<=k&&x*2<=100000&&!vis[x*2])
        {
            vis[x*2]=true;
            q.push(x*2);
            d[x*2]=d[x]+1;
        }
    }
}
int main()
{
    int n,m,i,j,t,k;
    //freopen("in.txt","r",stdin);
    while(~scanf("%d%d",&n,&k))
    {
        bfs(n,k);
        printf("%d\n",d[k]);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值