最短路 -B - Frogger POJ - 2253

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

题意:青蛙从第一个点跳到第二个点,可以途经剩下的所有点,求每次跳跃的最小距离。
题解:floyd算法和dijkstru算法把求最短路的操作改为求最短边即可。
AC代码:
//floyd AC
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 205;
double a[maxn][maxn];
int b[maxn],c[maxn];
int n,m;
double sum;
double leng(int x1,int y1,int x2,int y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
    int t=0;
    while(scanf("%d",&n))
    {
        if(n==0)
        {
            printf("\n");
            break;
        }
        t++;
        for(int i=1;i<=n;i++)
        {
          scanf("%d%d",&b[i],&c[i]);
        }
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            a[i][j]=a[j][i]=leng(b[i],c[i],b[j],c[j]);
        for(int k=1;k<=n;k++)
            for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
             a[i][j]=min(a[i][j],max(a[i][k],a[k][j]));
        printf("Scenario #%d\n",t);
        printf("Frog Distance = %.3f\n\n",a[1][2]);
    }
}
//dijkstru
#include<cstdio>
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn = 205;
double a[maxn][maxn];
int b[maxn],c[maxn];
bool vis[maxn];
double length[maxn];
int n,m;
double leng(int x1,int y1,int x2,int y2)
{
    return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
void dis()
{
    for(int i=1;i<=n;i++)
    {
        vis[i]=false;
        length[i]=a[1][i];
    }
    for(int i=1;i<=n;i++)
    {
        double u=50000;
        int v;
        for(int j=1;j<=n;j++)
        {
            if(!vis[j]&&length[j]<u)
            {
                u=length[j];
                v=j;
            }
        }
        vis[v]=true;
        for(int j=1;j<=n;j++)length[j]=min(length[j],max(length[v],a[v][j]));
    }
}
int main()
{
    int t=0;
    while(scanf("%d",&n))
    {
        if(n==0)
        {
            printf("\n");
            break;
        }
        t++;
        for(int i=1;i<=n;i++)scanf("%d%d",&b[i],&c[i]);
        for(int i=1;i<=n;i++)
            for(int j=i;j<=n;j++)
            a[i][j]=a[j][i]=leng(b[i],c[i],b[j],c[j]);
        dis();
        printf("Scenario #%d\n",t);
        printf("Frog Distance = %.3f\n\n",length[2]);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值