POJ 1050 To the Max

                                          To the Max

Description

Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1*1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle. 
As an example, the maximal sub-rectangle of the array: 

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 
is in the lower left corner: 

9 2 
-4 1 
-1 8 
and has a sum of 15. 

Input

The input consists of an N * N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N^2 integers separated by whitespace (spaces and newlines). These are the N^2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].

Output

Output the sum of the maximal sub-rectangle.

Sample Input

0 -2 -7 0 
9 2 -6 2 
-4 1 -4 1 
-1 8 0 -2 

Sample Output

15

题意:给定一个矩阵,找到一个矩阵和最大的子矩阵。

题解:如果是一维数组,那么就是O(N)前缀和扫过去,和小于0后去掉继续扫后面的。该题为二维数组,那么先求出行的前缀和,然后把他们看成一个数组,竖着扫一遍即可。

AC代码:

#include <iostream>
#include <cstring>
using namespace std;
#define _for(i,a,b) for(int i=a;i<=b;i++)
const int maxn = 106;
int n,a[maxn][maxn],sum[maxn][maxn];
int main(int argc, char const *argv[])
{
	cin>>n;
	_for(i,1,n)
	{
		_for(j,1,n)
		{
			cin>>a[i][j];
			sum[i][j]=sum[i][j-1]+a[i][j];
		}
	}
	int ans = 0;
	_for(i,1,n-1)
	{
		_for(k,i+1,n)
		{
			int now = 0;
			_for(j,1,n)
			{
				now+=(sum[j][k]-sum[j][i-1]);	
				ans = max(ans,now);
				if(now<=0)now = 0;
			}			
		}

	}
	cout<<ans<<endl;
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值