poj 2387 Til the Cows Come Home

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41791 Accepted: 14187

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

poj 2387 Til the Cows Come Home

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <string.h>
#include <queue>
#define N 10000 + 5
#define inf 0x7FFFFFFF
///spfa + 邻接表(邻接矩阵、vector模拟)
using namespace std;

int d[N];///记录最短路径
int p[N];/// 储存头节点,初始化为-1是为了方便判断某个点直接相连点是否找完了
bool vis[N];///记录是否入队
struct node{///记录节点信息
    int x;
    int c;///count
    int next;///指向p数组
}e[N];
void spfa(int s)
{
    d[s] = 0;
    queue<int>Q;
    Q.push(s);
    while(!Q.empty())
    {
        int t = Q.front();
        Q.pop();
        vis[t] = false;///
        for(int i=p[t]; i!=-1; i=e[i].next)
        {
            int w = e[i].c;
            int temp = e[i].x;
            if(w+d[t] < d[temp])
            {
                d[temp] = w+d[t];
                if(!vis[i])
                {
                    Q.push(temp);
                    vis[temp] = true;
                }
            }
        }
    }
}
int main()
{
    int t, n;
    int a, b, c;
    int temp = 0;

    scanf("%d%d", &t, &n);
    memset(p,-1,sizeof(p));
    memset(vis,false,sizeof(vis));
    fill(d,d+N,inf);
    while(t-->0)
    {
        scanf("%d%d%d", &a, &b, &c);
        e[temp].x = b;
        e[temp].c = c;
        e[temp].next = p[a];
        p[a] = temp++;
        e[temp].x = a;
        e[temp].c = c;
        e[temp].next = p[b];
        p[b] = temp++;
    }
    spfa(1);
    printf("%d", d[n]);

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值