There is a town with N citizens. It is known that some pairs of people are friends. According to the famous saying that “The friends of my friends are my friends, too” it follows that if A and B are friends and B and C are friends then A and C are friends, too.
Your task is to count how many people there are in the largest group of friends.
Input
Input consists of several datasets. The first line of the input consists of a line with the number of test cases to follow. The first line of each dataset contains tho numbers N and M, where N is the number of town's citizens (1≤N≤30000) and M is the number of pairs of people (0≤M≤500000), which are known to be friends. Each of the following M lines consists of two integers A and B (1≤A≤N, 1≤B≤N, A≠B) which describe that A and B are friends. There could be repetitions among the given pairs.
Output
The output for each test case should contain one number denoting how many people there are in the largest group of friends.
Sample Input | Sample Output |
2 3 2 1 2 2 3 10 12 1 2 3 1 3 4 5 4 3 5 4 6 5 2 2 1 7 10 1 2 9 10 8 9 | 3 6 |
维护一个集合内元素的数量
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 30010;
int fa[maxn],num[maxn],ans;
int find(int u){
return fa[u] == u ? u : fa[u] = find(fa[u]);
}
void Union(int u,int v){
int a = find(u);
int b = find(v);
if(a != b){
fa[a] = b;
num[a] += num[b];
num[b] = num[a];
ans = max(ans,num[b]);
}
}
int main(){
int kase,n,m,a,b;
scanf("%d",&kase);
while(kase--){
scanf("%d%d",&n,&m);
for(int i = 1;i <= n;i++){
fa[i] = i;
num[i] = 1;
}
ans = 0;
for(int i = 0;i < m;i++){
scanf("%d%d",&a,&b);
Union(a,b);
}
printf("%d\n",ans);
}
return 0;
}