UVA 10608 Friends

There is a town with N citizens. It is known that some pairs of people are friends. According to the famous saying that “The friends of my friends are my friends, too” it follows that if A and B are friends and B and C are friends then A and C are friends, too.

 

Your task is to count how many people there are in the largest group of friends.

 

Input

Input consists of several datasets. The first line of the input consists of a line with the number of test cases to follow. The first line of each dataset contains tho numbers N and M, where N is the number of town's citizens (1≤N≤30000) and M is the number of pairs of people (0≤M≤500000), which are known to be friends. Each of the following M lines consists of two integers A and B (1≤A≤N, 1≤B≤N, A≠B) which describe that A and B are friends. There could be repetitions among the given pairs.

 

Output

The output for each test case should contain one number denoting how many people there are in the largest group of friends.

 

Sample Input

Sample Output

2

3 2

1 2

2 3

10 12

1 2

3 1

3 4

5 4

3 5

4 6

5 2

2 1

7 10

1 2

9 10

8 9

3

6


题意:一个镇上有N个人,他们之间有M组朋友关系。有一句名言说:“我朋友的朋友也是我的朋友”。问朋友最多的那个人能有多少朋友。
考察内容:并查集的基本操作
并操作
查操作
维护一个集合内元素的数量

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 30010;
int fa[maxn],num[maxn],ans;

int find(int u){
    return fa[u] == u ? u : fa[u] = find(fa[u]);
}

void Union(int u,int v){
    int a = find(u);
    int b = find(v);
    if(a != b){
        fa[a] = b;
        num[a] += num[b];
        num[b] = num[a];
        ans = max(ans,num[b]);
    }
}

int main(){
    int kase,n,m,a,b;
    scanf("%d",&kase);
    while(kase--){
        scanf("%d%d",&n,&m);
        for(int i = 1;i <= n;i++){
            fa[i] = i;
            num[i] = 1;
        }
        ans = 0;
        for(int i = 0;i < m;i++){
            scanf("%d%d",&a,&b);
            Union(a,b);
        }
        printf("%d\n",ans);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值