[ACM] POJ 3096 Surprising Strings (map的使用)

286 篇文章 140 订阅
6 篇文章 1 订阅

Surprising Strings
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 5783 Accepted: 3792

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the "Puzzling Adventures" column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*

Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

Source


解题思路:

判断一个字符串是不是surpring。

条件:该字符串的所有D-pairs,D是字符串中两个字母的距离, 如果所有的D-pairs都不同,那么该字符串是D-unique。如果对所有的距离D,都满足D-unique,那么字符串就是surpring.

比如ZGBG

0-pairs :  ZG  GB BG  不相同,是0-unique

1-pairs :  ZB  GG        不相同,是1-unique

2-pairs:   ZG               不相同,是2-unique

综上,ZGBG是surpring

每一个D-pairs进行判断,如果在判断一个D-pairs过程中有相同的,那么该字符串肯定不是surpring。

用map<string,bool> 来判断是否字符串已经出现过,要注意其声明的位置,要在每一层D循环里面声明。

代码:

#include <iostream>
#include <stdio.h>
#include <map>
#include <string.h>
using namespace std;
char str[80];

int main()
{
    while(scanf("%s",str)!=EOF&&str[0]!='*')
    {
        int len=strlen(str);
        if(len<=2)
        {
            cout<<str<<" is surprising."<<endl;
            continue;
        }
        bool ok=1;//是surpring
        for(int d=0;d<=len-2;d++)//距离d
        {
            bool dtap=1;//是D-unique
            map<string,bool>mp;//注意其声明的位置
            for(int s=0;s<=len-2&&s+d+1<len;s++)
            {
                string temp="";
                temp+=str[s];
                temp+=str[s+d+1];
                if(mp[temp])//该字符串出现过
                {
                    dtap=0;
                    break;
                }
                else
                    mp[temp]=1;
            }
            if(!dtap)
            {
                ok=0;
                break;
            }
        }
        if(ok)
            cout<<str<<" is surprising."<<endl;
        else
            cout<<str<<" is NOT surprising."<<endl;
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值