[ACM] POJ 3254 Corn Fields(状态压缩)

286 篇文章 140 订阅
49 篇文章 0 订阅
Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8062 Accepted: 4295

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes row i of the pasture with N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.

Source

 

解题思路:

题意为有n行m列的长方形,分成n*m个格子,每个格子标记为0或1,在这些格子里面放牛,其中1代表该格子可以放牛,0代表不能放牛,且相邻的两个格子不能同时有牛,问总的方案数。

思想为状态压缩,把每一行放牛的状态看作一个二进制数,dp[i][j]表示第i行状态为j时前i行共有的方案数。

代码:

#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;
const int mod=100000000;
const int maxn=12;
int dp[maxn+1][(1<<maxn)+1];
int num[maxn+1];
int n,m;

bool check(int i,int x)//检查第i行出现状态x是否合法
{
    if((x&num[i])!=x)//很巧妙,判断第i行出现的状态x是否合法,为什么这么写,因为0的地方不能放牛,
    //合法状态与原始状态0位且为0,原始状态1位的地方与合法状态对应位且都等于合法状态位上的数字
        return 0;
    if(x&(x>>1)||x&(x<<1))//不能有相邻的两个1
        return 0;
    return 1;
}

int main()
{
    cin>>n>>m;
    int x;
    memset(num,0,sizeof(num));
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
    {
        cin>>x;
        if(x)
            num[i]=num[i]|(1<<(j-1));//把每一行的状态保存到num[i]中去
    }
    int Max=(1<<m);
    dp[0][0]=1;//注意这一句啊!
    for(int i=1;i<=n;i++)//枚举每一行
    {
        for(int j=0;j<Max;j++)
        {
            if(!check(i,j))
                continue;
            for(int k=0;k<Max;k++)
                if((j&k)==0)
            {
                dp[i][j]+=dp[i-1][k];
                if(dp[i][j]>=mod)
                    dp[i][j]%=mod;
            }
        }
    }
    int ans=0;
    for(int i=0;i<Max;i++)
    {
        ans+=dp[n][i];
        if(ans>=mod)
            ans%=mod;
    }
    cout<<ans;
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值