1084 Broken Keyboard

1084 Broken Keyboard
On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:
Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:
For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:
7_This_is_a_test
_hs_s_a_es
Sample Output:
7TI
题目大意:键盘坏掉了,一些键无法显示。给定原本要显示的字符串,和实际显示的字符串,找出哪些键坏掉了。
分析:遍历两个字符串,i为第一个字符串计数,j为第二个字符串计数。
当(j>=s2.length()||s1[i]!=s2[j])成立时,对当前字符进行判断,如果没被输出过则输出。
相反j++;
参考代码:

#include<string>
#include<set>
#include<iostream>
using namespace std;
int main() {
	string s1, s2;
	int i = 0, j = 0;
	char ch;
	getline(cin, s1);
	getline(cin, s2);
	set<char>s;
	for (i = 0; i < s1.size(); i++) {
		if (j >= s2.size() || s1[i] != s2[j]) {
			ch = s1[i];
			if (isalpha(ch))ch = toupper(ch);
			if (s.count(ch) == 0) {
				cout << ch;
				s.insert(ch);
			}
		}
		else {	j++;}
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值