1084 Broken Keyboard (20 分)

On a broken keyboard, some of the keys are worn out. So when you type some sentences, the characters corresponding to those keys will not appear on screen.

Now given a string that you are supposed to type, and the string that you actually type out, please list those keys which are for sure worn out.

Input Specification:

Each input file contains one test case. For each case, the 1st line contains the original string, and the 2nd line contains the typed-out string. Each string contains no more than 80 characters which are either English letters [A-Z] (case insensitive), digital numbers [0-9], or _ (representing the space). It is guaranteed that both strings are non-empty.

Output Specification:

For each test case, print in one line the keys that are worn out, in the order of being detected. The English letters must be capitalized. Each worn out key must be printed once only. It is guaranteed that there is at least one worn out key.

Sample Input:

7_This_is_a_test
_hs_s_a_es

Sample Output:

7TI

  思路:这里其实就是使用sting的 find() 的函数,步骤是遍历s1字符串每遍历到一个字符若在s2字符串中没有找到.则去存储结果的vector中查找是否有该字符以及大小写(使用 toupper()和tolower()),若无则添加进去。 最后在输出时,若为小写则转化为大写。

#include<iostream>
#include<string>
#include<stdio.h>
#include<string.h>
#include<vector>
#include<set>
#include<map>
#include<unordered_map>
#include<queue>
#include<algorithm>
#include<cmath>
using namespace std;
#define ll long long
#define vi vector<int>
#define pii pair<int, int>
#define x first
#define y second
const int maxn=110;
string s1,s2;
vector<char> vc;
bool findchar(char c)
{
    for(vector<char>::iterator it=vc.begin();it!=vc.end();it++)
    {
        if(c==*it||toupper(c)==*it||tolower(c)==*it)
        {
            return true;
            break;
        }
    }
    return false;
}
int main()
{
    cin>>s1>>s2;
    int l1=s1.length(),l2=s2.length();
    for(int i=0;i<l1;i++)
    {
        int j=s2.find(s1[i]);
        if(j==-1)
        {
            if(!findchar(s1[i])) vc.push_back(s1[i]);
        }
    }
    for(int i=0;i<vc.size();i++)
    {
       if(vc[i]>='a'&&vc[i] <='z') vc[i]=toupper(vc[i]);
       cout<<vc[i];
    }
    cout<<endl;
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值