1104 Sum of Number Segments

1104 Sum of Number Segments
Given a sequence of positive numbers, a segment is defined to be a consecutive subsequence. For example, given the sequence { 0.1, 0.2, 0.3, 0.4 }, we have 10 segments: (0.1) (0.1, 0.2) (0.1, 0.2, 0.3) (0.1, 0.2, 0.3, 0.4) (0.2) (0.2, 0.3) (0.2, 0.3, 0.4) (0.3) (0.3, 0.4) and (0.4).

Now given a sequence, you are supposed to find the sum of all the numbers in all the segments. For the previous example, the sum of all the 10 segments is 0.1 + 0.3 + 0.6 + 1.0 + 0.2 + 0.5 + 0.9 + 0.3 + 0.7 + 0.4 = 5.0.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N, the size of the sequence which is no more than 10
​5
​​ . The next line contains N positive numbers in the sequence, each no more than 1.0, separated by a space.

Output Specification:
For each test case, print in one line the sum of all the numbers in all the segments, accurate up to 2 decimal places.

Sample Input:
4
0.1 0.2 0.3 0.4
Sample Output:
5.00
题目大意:
给定一个集合,找到连续子集(元素在集合中是连续的),然后求出个子集和的和。
分析:千万不要希望求出各子集和,我们的目标是解决问题,所以只要知道每个元素出现的次数即可解决问题。元素出现的次数是多少呢,只要稍微动下脑筋就会发现是(n+1-i)*i,i指示元素在集合中的位序(第几个元素)。
参考代码:

#include<iostream>
using namespace std;
int main() {
	double num,sum=0.0;  int n;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		scanf_s("%lf", &num);
		sum += num*i*(n + 1 - i);
		//	sum+=num*i*(n+1-i);
		//	sum+=num*(n+1-i)*i;
		//	sum+=i*num*(n+1-i);
		//sum += i * (n + 1 - i)*num;如果乘积的顺序是这样,就有两个测试点无法
		//通过,至于原因是什么,在下也不明白,实在搞不懂。
		
		//	sum=sum+(n+1-i)*i*num;
		//	sum += (n + 1 - i)*i*num;
	}
	printf("%.2f", sum);

	return 0;
}

欢迎评论!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值