1108 Finding Average

1108 Finding Average
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A legal input is a real number in [−1000,1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤100). Then N numbers are given in the next line, separated by one space.

Output Specification:
For each illegal input number, print in a line ERROR: X is not a legal number where X is the input. Then finally print in a line the result: The average of K numbers is Y where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output Undefined instead of Y. In case K is only 1, output The average of 1 number is Y instead.

Sample Input 1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
Sample Output 1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
Sample Input 2:
2
aaa -9999
Sample Output 2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
分析:题目已经给出无效输入的样式,因此需要考虑这些给定格式的无效输入。小数点多个,有效位超过2位,含有其他的如字母的字符的输入。
参考代码:

#include<iostream>
#include<vector>
#include<string>
using namespace std;
bool func(string s) {
	int dot = 0, youxiaowei = 0;
	for (auto val : s) {
		if (!(isdigit(val) || val == '.' || val == '-'))return false;
		else {
			if (val == '.') {
				dot++;
				if (dot > 1)return false;
			}
			else if (dot != 0) {
				youxiaowei++;
				if (youxiaowei > 2)return false;
			}
		}
	}
	if (stof(s) <= 1000 && stof(s) >= -1000)  //当时就因为写成-100,结果调试了一个多小时,细节啊!!!
		return true;
	else return false;
}
int main() {
	int n, cnt = 0; double  sum = 0.0;
	string num;
	cin >> n;
	for (int i = 1; i <= n; i++) {
		cin >> num;
		if (func(num)) {
			sum += stof(num);
			cnt++;
		}
		else {
			printf("ERROR: %s is not a legal number\n", num.c_str());
		}
	}
	printf("The average of %d number", cnt);
	if (cnt != 1)cout << "s";
	printf(" is ");
	if (cnt == 0)cout << "Undefined";
	else printf("%.2f", sum / cnt);

	return 0;
}

欢迎评论!!!

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值