Building Shops HDU - 6024(动态规划)

HDU’s n classrooms are on a line ,which can be considered as a number line. Each classroom has a coordinate. Now Little Q wants to build several candy shops in these n classrooms.

The total cost consists of two parts. Building a candy shop at classroom i would have some cost ci. For every classroom P without any candy shop, then the distance between P and the rightmost classroom with a candy shop on P’s left side would be included in the cost too. Obviously, if there is a classroom without any candy shop, there must be a candy shop on its left side.

Now Little Q wants to know how to build the candy shops with the minimal cost. Please write a program to help him.
Input
The input contains several test cases, no more than 10 test cases.
In each test case, the first line contains an integer n(1≤n≤3000), denoting the number of the classrooms.
In the following n lines, each line contains two integers xi,ci(−109≤xi,ci≤109), denoting the coordinate of the i-th classroom and the cost of building a candy shop in it.
There are no two classrooms having same coordinate.
Output
For each test case, print a single line containing an integer, denoting the minimal cost.
Sample Input
3
1 2
2 3
3 4
4
1 7
3 1
5 10
6 1
Sample Output
5
11
题意:有n个位置有可能建立糖果店,最左边的位置一定建立糖果店,后面的位置如果建立糖果店,花费就是建立糖果店的花费,如果不建立糖果店,花费就是到左边最靠近它的糖果店的距离。问最小花费是多少。
思路:当前是否建立糖果店对结果是有后效性的,因此需要考虑动态规划。如果当前需要建立糖果店,那么就在前一个点是否建立糖果店的代价中取一个最小的。如果不需要建立糖果店,就在前面找一个建立糖果店的点,再加上距离花费就可以。
在这里插入图片描述
如图所示:假如4不建立糖果店,它现在找到了1,1是建立糖果店的。那么距离怎么算?我们可以发现,1-2的距离是计算了3次,2-3是两次,3-4是1次。次数分别是4-1,4-2,4-3.规律就很明显了。
状态转移方程:
在这里插入图片描述
代码如下:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=3e3+100;
struct node{
	int x;ll val;
	bool operator<(const node &a)const{
		return x<a.x;
	}
}p[maxx];
ll dp[maxx][2];
int n;

int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=1;i<=n;i++) scanf("%d%lld",&p[i].x,&p[i].val);
		memset(dp,inf,sizeof(dp));
		sort(p+1,p+1+n);
		dp[1][1]=p[1].val;
		dp[1][0]=inf;
		for(int i=2;i<=n;i++)
		{
			dp[i][1]=min(dp[i-1][1],dp[i-1][0])+p[i].val;
			ll dis=0;
			for(int j=i-1;j>=1;j--)
			{
				dis=dis+(ll)(i-j)*(p[j+1].x-p[j].x);//这里一定要用long long。
				dp[i][0]=min(dp[i][0],dp[j][1]+dis);
			}
		}
		printf("%lld\n",min(dp[n][1],dp[n][0]));
	}
	return 0;
}

努力加油a啊,(o)/~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
好的,我可以给你一些指导来创建和使用shops数据库。 首先,你需要安装一个关系型数据库管理系统(RDBMS),例如MySQL、PostgreSQL或Microsoft SQL Server。这些RDBMS都提供了创建和管理数据库的工具。 一旦你安装了RDBMS,你可以使用SQL(结构化查询语言)来创建数据表和插入数据。下面是一个示例的SQL代码来创建一个名为“shops”的数据库: ``` CREATE DATABASE shops; ``` 接下来,你可以创建一个名为“products”的表来存储商品信息,例如商品名称、价格和库存量。下面是一个示例的SQL代码: ``` CREATE TABLE products ( id INT NOT NULL AUTO_INCREMENT, name VARCHAR(255) NOT NULL, price DECIMAL(10,2) NOT NULL, stock INT NOT NULL, PRIMARY KEY (id) ); ``` 这将创建一个名为“products”的表,其中包含四个列:id、name、price和stock。id列是自动增量的主键,确保每个商品都有一个唯一的标识符。name列存储商品名称,price列存储商品价格,stock列存储商品库存量。 一旦你创建了“products”表,你可以使用INSERT语句向表中插入数据。例如,下面是一个示例的SQL代码来插入一些商品信息: ``` INSERT INTO products (name, price, stock) VALUES ('T-shirt', 19.99, 100), ('Jeans', 49.99, 50), ('Sneakers', 79.99, 25); ``` 这将向“products”表中插入三个商品,分别是T-shirt、Jeans和Sneakers,每个商品都有一个价格和库存量。 一旦你向表中插入了数据,你可以使用SELECT语句来查询数据。例如,下面是一个示例的SQL代码来查询所有商品的名称和价格: ``` SELECT name, price FROM products; ``` 这将返回一个结果集,其中包含所有商品的名称和价格。 当然,这只是一个简单的示例,你可以根据自己的需求创建更复杂的表和查询。希望这些指导可以帮助你创建和使用shops数据库。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值