Doing Homework HDU - 1074(状压dp)

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test, 1 day for 1 point. And as you know, doing homework always takes a long time. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=15) which indicate the number of homework. Then N lines follow. Each line contains a string S(the subject’s name, each string will at most has 100 characters) and two integers D(the deadline of the subject), C(how many days will it take Ignatius to finish this subject’s homework).

Note: All the subject names are given in the alphabet increasing order. So you may process the problem much easier.
Output
For each test case, you should output the smallest total reduced score, then give out the order of the subjects, one subject in a line. If there are more than one orders, you should output the alphabet smallest one.
Sample Input
2
3
Computer 3 3
English 20 1
Math 3 2
3
Computer 3 3
English 6 3
Math 6 3
Sample Output
2
Computer
Math
English
3
Computer
English
Math

Hint
In the second test case, both Computer->English->Math and Computer->Math->English leads to reduce 3 points, but the
word “English” appears earlier than the word “Math”, so we choose the first order. That is so-called alphabet order.
思路:因为n=15,不是很大,因此我们可以把所有的状态都枚举一遍,不断的去更新每一种状态的最小值,最终输出dp[(1<<n)-1]就可以了。具体看代码:

#include<bits/stdc++.h>
#define ll long long
#define inf 0x3f3f3f3f
using namespace std;

const int maxx=16;
const int maxn=(1<<maxx);
struct node{
	string s;
	int ed,vl;
}p[maxx];
int dp[maxn],tme[maxn],pre[maxn],bk[maxn];
int n;

inline void init()
{
	memset(dp,0,sizeof(dp));
	memset(pre,-1,sizeof(pre));
	memset(tme,0,sizeof(tme));
}
inline void dfs(int x)
{
	if(x==0) return ;
	dfs(pre[x]);
	cout<<p[bk[x]].s<<endl;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=1;i<=n;i++) cin>>p[i].s>>p[i].ed>>p[i].vl;
		init();
		int All=1<<n;All-=1;
		int tmp,sum;
		for(int i=1;i<=All;i++)//枚举状态,这里枚举的就是每一种可能发生的情况
		{
			dp[i]=inf;
			for(int j=n;j>=1;j--)//正序的话,最小值计算的是没有问题的,但是无法按照题目要求的顺序输出
			{
				tmp=1<<(j-1);
				if(!(i&tmp)) continue;
				sum=tme[i-tmp]+p[j].vl-p[j].ed;//i-tmp,例如i=001010,tmp=001000,i-tmp=000010.就代表第五个作业先做,第三个作业再做。
				if(sum<0) sum=0;
				if(sum+dp[i-tmp]<dp[i])
				{
					dp[i]=dp[i-tmp]+sum;
					tme[i]=tme[i-tmp]+p[j].vl;
					pre[i]=i-tmp;
					bk[i]=j;
				}
			}
		}
		printf("%d\n",dp[All]);
		dfs(All);
	}
	return 0;
}

说实话,一开始真没想到是状压。。
努力加油a啊,(o)/~

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

starlet_kiss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值