1049
Climbing Worm
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 22179 Accepted Submission(s): 15159
Problem Description
An inch worm is at the bottom of a well n inches deep. It has enough energy to climb u inches every minute, but then has to rest a minute before climbing again. During the rest, it slips down d inches. The process of climbing and resting then repeats. How long before the worm climbs out of the well? We'll always count a portion of a minute as a whole minute and if the worm just reaches the top of the well at the end of its climbing, we'll assume the worm makes it out.
Input
There will be multiple problem instances. Each line will contain 3 positive integers n, u and d. These give the values mentioned in the paragraph above. Furthermore, you may assume d < u and n < 100. A value of n = 0 indicates end of output.
Output
Each input instance should generate a single integer on a line, indicating the number of minutes it takes for the worm to climb out of the well.
Sample Input
10 2 1
20 3 1
0 0 0
Sample Output
17
19
Source
East Central North America 2002
题意概括:
类似于青蛙爬井的问题,井有n米深,每天向上爬u米,乡下掉d米,问多少天爬出井外。
AC代码:
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner s = new Scanner(System.in);
while(s.hasNextInt())
{
int n = s.nextInt();
int u = s.nextInt();
int d = s.nextInt();
int sum = 0, x = 0;
if(n == 0)
{
break;
}
while(x < n)
{
x += u;
sum ++;
if(x >= n)
{
break;
}
x -= d;
sum ++;
}
System.out.println(sum);
}
}
}