Bi-shoe and Phi-shoe

题目:

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them . Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n . So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T ( ≤ 100) , denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 10 6 ] .

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

题意:

给出学生数,每个学生对应一个幸运值,每个竹子对应的score都要大于等于学生的幸运值(某个数的score值指小于等于该数的并且与该数互质的数的个数),竹子的长度就是价钱,求出买竹子的最小价钱;

分析:

很显然是关于欧拉函数的问题;(一下摘自百度百科)

通式:

 

其中p1, p2……pn为x的所有质因数,x是不为0的整数。

φ(1)=1(和1互质的数(小于等于1)就是1本身)。

注意:每种质因数只一个。 比如12=2*2*3那么φ(12)=12*(1-1/2)*(1-1/3)=4

若n是质数p的k次幂,

  

,因为除了p的倍数外,其他数都跟n互质。

设n为正整数,以 φ(n)表示不超过n且与n互素的正整数的个数,称为n的欧拉函数值

φ:N→N,n→φ(n)称为欧拉函数。

欧拉函数是积性函数——若m,n互质,

 

特殊性质:当n为奇数时,

  

, 证明与上述类似。

若n为质数则

 

很显然我们要用到最后一个性质,首先用筛法写出素数表,然后从幸运值+1开始判断,遇到的第一个素数就是对应的的最小的竹子的价钱;

代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int zhu[10005],t,n;
int book[1000005];
void solve()
{
    int i,j;
    int m=sqrt(1000005.5);//四舍五入
    memset(book,0,sizeof(book));
    for(i=2;i<m;i++)
        if(!book[i])
        {
        for(j=i*i;j<=1000005;j+=i)
            book[j]=1;
        }
    return ;
}
int main()
{
    solve();
    int i,x,j,casee=0;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        long long sum=0;
        for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            for(j=x+1; ; j++)
            {
                if(!book[j])
                {
                    sum+=j;
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",++casee,sum);

    }
    return 0;
}
 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值