Cure

Given an integer nn, we only want to know the sum of 1/k^21/k2 where kk from 11 to nn.

Input Format

There are multiple cases.

For each test case, there is a single line, containing a single positive integer nn.

The input file is at most 1M1M.

Output Format

The required sum, rounded to the fifth digits after the decimal point.

样例输入

1
2
4
8
15

样例输出

1.00000
1.25000
1.42361
1.52742
1.58044

题目来源

ACM-ICPC 2016 Qingdao Preliminary Contest

题意:

输入n,求出n想倒数平方和;

分析:

之前做过一道类似的,求倒数和,用的是分段打表或者欧拉公式,但是倒数平方和的公式是极限时趋近于一个数,因此在n很小的时候打表计算,很大的时候就固定为一个数;但是试了很多次还是错误,其实一直在疑惑这道题的范围是多少,但是这道题没有说范围,因此我们需要用字符串输入!!!!!

代码:

#include<stdio.h>
#include<math.h>
#include<string.h>
#include<algorithm>
using namespace std;
double eps=1e-8;
const double PI = 4.0*atan(1.0);
const int maxn=1000000;
double p[maxn+10];
long long n;
char v[10000000];
void solve()
{
    p[0]=0.0;
    double s=0.0;
    for(int i=1;i<=maxn;i++)
    {
        s=s+1.0/double(double(i)*double(i));
        p[i]=s;
    }
}
int main()
{
    solve();
    while(scanf("%s",v)!=EOF)
    {
        if(strlen(v)>7)
            n=maxn;
        else
          sscanf(v,"%lld",&n);
          if(n>1000000)
           n=maxn;
        printf("%.5lf\n",p[n]);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值