HDU 4135 Co-prime(容斥原理求互质数)

Co-prime

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1339 Accepted Submission(s): 495


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.

Sample Input
  
  
2 1 10 2 3 15 5

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.

Source

Recommend
lcy | We have carefully selected several similar problems for you: 1796 1434 3460 1502 4136


容斥原理说明http://www.cppblog.com/vici/archive/2011/09/05/155103.html

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <sstream>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <ctime>
using namespace std;
typedef long long LL;

LL solve (LL n, LL r) {
        vector<LL> p;
        for (LL i=2; i*i<=n; ++i)
               if (n % i == 0) {
                       p.push_back (i);
                       while (n % i == 0)
                               n /= i;
               }
        if (n > 1){
               p.push_back (n);
 	}
        LL sum = 0;
        for (LL msk=1; msk<(1<<p.size()); ++msk) {
               LL mult = 1,bits = 0;
               for (LL i=0; i<(LL)p.size(); ++i)
                       if (msk & (1<<i)) {
                               ++bits;
                               mult *= p[i];
                       }
 
               LL cur = r / mult;
               if (bits % 2 == 1){
                       sum += cur;
                   }else{
                       sum -= cur;
                   }
        }
        return r - sum;
}
int main(){

    LL a,b,n,t,g = 0;;
	scanf("%I64d",&t);
		while(t--){
			g++;
		scanf("%I64d%I64d%I64d",&a,&b,&n);
		printf("Case #%I64d: %I64d\n",g,solve(n,b)-solve(n,a-1));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值