github.com/gogo/protobu: invalid pseudo-version: revision is shorter than canonical

        编译执行go mod tidy时,出现了这个错误,挺恶心的:

        xxx  requires
        github.com/micro/go-plugins@v1.3.0 requires
        k8s.io/api@v0.0.0-20190726022912-69e1bce1dad5 requires
        github.com/gogo/protobuf@v0.0.0-20190410021324-65acae22fc9: invalid pseudo-version: revision is shorter than canonical

 

        搞了大半天,终于找到原因:

        https://github.com/golang/go/issues/3439

 

        解决办法,在go.mod中加:

replace github.com/gogo/protobuf v0.0.0-20190410021324-65acae22fc9 => github.com/gogo/protobuf v0.0.0-20190723190241-65acae22fc9d

       搞定。

 

 

涛歌依旧 CSDN认证博客专家 涛哥挺nice的
不积跬步,无以至千里;不积小流,无以成江海。骐骥一跃,不能十步;驽马十驾,功在不舍。锲而舍之,朽木不折;锲而不舍,金石可镂。更多干货和精彩内容,欢迎扫码关注公众号
©️2020 CSDN 皮肤主题: 技术工厂 设计师:CSDN官方博客 返回首页