PTA-甲级 1033 To Fill or Not to Fill(测试点2)

PTA-甲级 1033 To Fill or Not to Fill(测试点2)

With highways available, driving a car from Hangzhou to any other city is easy. But since the tank capacity of a car is limited, we have to find gas stations on the way from time to time. Different gas station may give different price. You are asked to carefully design the cheapest route to go.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 positive numbers: Cmax (≤ 100), the maximum capacity of the tank; D (≤30000), the distance between Hangzhou and the destination city; Davg (≤20), the average distance per unit gas that the car can run; and N (≤ 500), the total number of gas stations. Then N lines follow, each contains a pair of non-negative numbers: Pi, the unit gas price, and Di (≤D), the distance between this station and Hangzhou, for i=1,⋯,N. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the cheapest price in a line, accurate up to 2 decimal places. It is assumed that the tank is empty at the beginning. If it is impossible to reach the destination, print The maximum travel distance = X where X is the maximum possible distance the car can run, accurate up to 2 decimal places.

Sample Input 1:

50 1300 12 8
6.00 1250
7.00 600
7.00 150
7.10 0
7.20 200
7.50 400
7.30 1000
6.85 300

Sample Output 1:

749.17

Sample Input 2:

50 1300 12 2
7.10 0
7.00 600

Sample Output 2:

The maximum travel distance = 1200.00

知识点: 贪心算法

算法:

if 最近一站距离<cmax*davg
	去不了终点了;
	break;
else 在能到达范围内,
	if 存在更低油价
		选择最近的油价更低的作为下一站;
	else if 能到终点了
		去终点;
	else 去能到达的最远的一站;

注意点:

1.不要直接用测试里的12、600的数据…这是输入进来的不是自带的(修正后测试点1、6过了)

2.测试点2是第一个站不在原点的情况,直接输出 The maximum travel distance = 0.00

3.测试点4错误可能是到终点的情况出现了问题(猜测)

代码:

#include<iostream>
#include<algorithm>
using namespace std;
int cmax,d,davg,n;
double total;
struct stu{
	int dis;
	double pri;
} sta[505];
bool comp(stu a, stu b){
	return a.dis<b.dis;
}
int main(){
	total=0.0;
	double cont=0.0;
	double distance=0.0;
	bool end=false;
	cin>>cmax>>d>>davg>>n;
	for(int i=0; i<n; i++){
		cin>>sta[i].pri>>sta[i].dis;
	}
	sta[n].dis=d;
	sta[n].pri=0;
	sort(sta, sta+n, comp);
	for(int i=0; i<n; i++){
		if(sta[i+1].dis-sta[i].dis>cmax*davg){
			distance+=cmax*davg;
			break;
		}
		for(int j=i+1; j<=n; j++){
			if(sta[j].dis-sta[i].dis>cmax*davg){
				total+=sta[i].pri*(cmax-cont); 	// 加满 
				cont=(cmax-(sta[j-1].dis-sta[i].dis)*1.00/davg)*1.00; 	// 去完下一站剩的油 
				i=j-2; 	//下一站
				distance=sta[j-1].dis; 
				break;
			}
			else if(j==n){
				total+=sta[i].pri*(sta[j].dis-sta[i].dis-cont*davg)/davg;
				cont=0; 	// 到终点油用完 
				end=true; 	// 到终点了 
				distance=d; 
				break;
			}
			else if(sta[j].pri<sta[i].pri){
				total+=sta[i].pri*(sta[j].dis-sta[i].dis-cont*davg)/davg;
				cont=0; 	//到一站油刚好用完 
				i=j-1;	// 下一站 
				distance=sta[j].dis; 
				break;
			}
		}
		if(end){
			break;
		}
	}
	if(sta[0].dis!=0){
		printf("The maximum travel distance = 0.00\n");
	}
	else if(end){
		printf("%.2f\n", total);
	}
	else{
		printf("The maximum travel distance = %.2f\n", distance);
	}
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值