hdu1162 Eddy's picture 最小生成树 prim

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10218    Accepted Submission(s): 5162


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point. 

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points. 
 

Sample Input
  
  
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
  
  
3.41
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1102  1217  1598  1596  1116 
 

Statistic |  Submit |  Discuss |  Note

如果能用一句话形容我现在的心情  我真想说  :我真是日了狗了。。。

一天一道题没做出来  只能虐虐水题  心情不爽 很想发泄

#include <stdio.h>
#include <math.h>
#define inf 0x3fffffff
struct node
{
	double x,y;
}p[105];
int n;
double line[105][105];
double getDist(node p1,node p2)
{
	return sqrt(pow(p1.y-p2.y,2)+pow(p1.x-p2.x,2));
}
void prim()
{
	double dist[105];
	for(int i=0;i<n;i++)
	dist[i]=inf;
	int now=0;
	double ans=0;
	for(int i=0;i<n-1;i++)
	{
		for(int j=0;j<n;j++)
		{
			if(dist[j]!=-1&&dist[j]>line[now][j])
			{
				dist[j]=line[now][j];
			}
		}
		
		dist[now]=-1;
		double min=inf;
		int x;
		for(int j=0;j<n;j++)
		{
			if(dist[j]!=-1&&min>dist[j])
			{
				min=dist[j];
				x=j;
			}
		}
		now=x;
		ans+=min;
	}
	printf("%.2lf\n",ans);
}
int main()
{
	while(~scanf("%d",&n))
	{
		for(int i=0;i<n;i++)
		{
			scanf("%lf %lf",&p[i].x,&p[i].y);
		}
		for(int i=0;i<n;i++)
		{
			line[i][i]=inf;
			for(int j=i+1;j<n;j++)
			{
				line[i][j]=line[j][i]=getDist(p[i],p[j]);
			}
		}
		prim();
	}
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值