YAPTCHA(数论,威尔逊定理)

YAPTCHA

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1059    Accepted Submission(s): 574


Problem Description
The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.


However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.
 

Input
The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).
 

Output
For each n given in the input output the value of Sn.
 

Sample Input
 
 
13 1 2 3 4 5 6 7 8 9 10 100 1000 10000
 

Sample Output
 
 
0 1 1 2 2 2 2 3 3 4 28 207 1609
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   2970  2966  2967  2968  2969 

数论知识点:威尔逊定理:若p为质数,则p|(p-1)!+1,所以当3*k+1为合数时,后面式子等于前面式子,则等于0,当3*k+1为质数时,式子为1,则可直接算出3*k+1为素数的数字,前缀和加起来即可。

#include<stdio.h>
#include <algorithm>
#include<iostream>
#include<string.h>
#include<vector>
#include<stdlib.h>
#include<math.h>
#include<queue>
#include<deque>
#include<ctype.h>
#include<map>
#include<set>
#include<stack>
#include<string>
#include<algorithm>
#define INF 0x3f3f3f3f
#define gcd(a,b) __gcd(a,b)
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define FAST_IO ios::sync_with_stdio(false)
using namespace std;
typedef long long ll;
inline ll read(){ll x=0,f=1;char c=getchar();for(;!isdigit(c);c=getchar()) if(c=='-') f=-1;for(;isdigit(c);c=getchar()) x=x*10+c-'0';return x*f;}

const int maxn=1e6+5;
const int mx = 3 * 1000000 + 7 + 1;
int vis[mx],a[maxn],sum[maxn];
void shai()
{
    for(int i=2;i<mx;i++)
        if(vis[i]==0)
        {
            if((i-7)%3==0)
                a[(i-7)/3]=1;
            for(int j=i*2;j<mx;j+=i) vis[j]=1;
        }
}

int main()
{
    shai();
    for(int i=2;i<maxn;i++)
        sum[i]=sum[i-1]+a[i];
    int t;
    cin>>t;
    while(t--)
    {
        int n;
        cin>>n;
        cout<<sum[n]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值