搜索专题:bfs和dfs

搜索

catch the cow

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input

5 17
Sample Output

4
Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

思路:bfs 因为要所需时间最短 所以每次一层一层从小的时间点找起来
农夫的移动方向有三种 +1 -1 *2;

#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
using namespace std;

const int maxn=1e5+10;
bool visit[maxn];
struct state{
    int position;
    int time;
    state(){}
    state(int p,int t):position(p),time(t){}
};

int bfs(int n,int k){
     queue<state>q;
    q.push(state(n,0));
    visit[n]=true;
    while(!q.empty()){
        state current=q.front();
        if(current.position==k){
            return current.time;
        }//如果现在的状态的位置就是牛的位置 返回时间
        q.pop();//否则将队首弹出 但是其实值已经保存在current
        for(int i=0;i<3;i++){//三种状态转移
            state next=current;
            if(i==0) {next.position-=1;} 
            else if(i==1) {next.position+=1;} 
            else{ next.position*=2;} 
            next.time+=1;
            if(next.position<0||next.position>1e5||visit[next.position]){
                continue;//位置不合法
            }
            q.push(next);
            visit[next.position]=true;
        }      
    }
    
}



int main(){
    int n,k;
    scanf("%d%d",&n,&k);
    //cin>>n>>k;
    memset(visit,false,sizeof(visit));
    printf("%d\n",bfs(n,k));
    //cout<<bfs(n,k);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值