Girls and Boys

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12341    Accepted Submission(s): 5824


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
  
  
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
  
  
5 2

题目大意:找到一个集合,使得其中的所有人之间不能恋爱。

解题思路:先找到能够恋爱的人的关系,再分析题目。

这里给出实例说话:例如样例中2 

0 1 2

1 0

2 0

中,0和1可以恋爱,0和2也可以恋爱,但是1和2之间不能恋爱,则1 2之间组成的集合的元素的个数就是题中的解。那么我们就要研究如何把0去掉,去掉了他,我们就有了最大集合元素个数。这个时候就要用到匈牙利算法--二分图匹配。

我们可以通过二分匹配的算法求出能够恋爱的组数,因为这里是双向图,所以我们现在得到的组数实际是人数并不是组数,所以我们得到的数要除以2,所得到的数才是能够恋爱的最大组数,这个时候我们只需要拆散他们就行了。扔一个,留一个。去掉的人不加入集合,留下的人加入集合,就得到了题目所求的东西。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int map[1000][1000];
int vis[1000];
int match[1000];
int n,m;
int find(int x)
{
    int i;
    for(i=0; i<n; i++)
    {
        if(vis[i]==0&&map[x][i]==1)
        {
            vis[i]=1;
            if(match[i]==-1||find(match[i]))
            {
                match[i]=x;
                return 1;
            }
        }
    }
    return 0;
}
int main()
{
    int i,j,t;
    while(scanf("%d",&n)!=EOF)
    {
        memset(map,0,sizeof(map));
        memset(match,-1,sizeof(match));
        for(i=0;i<n;i++)
        {
            int x,y,num;
             scanf("%d: (%d)",&x,&num);
            for(j=0;j<num;j++)
            {
                scanf("%d",&y);
                map[x][y]=1;
            }
        }
        int sum=0;
        for(i=0;i<n;i++)
        {
            memset(vis,0,sizeof(vis));
            if(find(i))
                sum++;
        }
        printf("%d\n",n-sum/2);
    }
    return 0;
}



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值