Seaside HDU 3665 【Dijkstra】

20 篇文章 0 订阅
11 篇文章 0 订阅

                                            Seaside

   Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                          Total Submission(s): 1880    Accepted Submission(s): 1372


 

Problem Description

XiaoY is living in a big city, there are N towns in it and some towns near the sea. All these towns are numbered from 0 to N-1 and XiaoY lives in the town numbered ’0’. There are some directed roads connecting them. It is guaranteed that you can reach any town from the town numbered ’0’, but not all towns connect to each other by roads directly, and there is no ring in this city. One day, XiaoY want to go to the seaside, he asks you to help him find out the shortest way.

Input

There are several test cases. In each cases the first line contains an integer N (0<=N<=10), indicating the number of the towns. Then followed N blocks of data, in block-i there are two integers, Mi (0<=Mi<=N-1) and Pi, then Mi lines followed. Mi means there are Mi roads beginning with the i-th town. Pi indicates whether the i-th town is near to the sea, Pi=0 means No, Pi=1 means Yes. In next Mi lines, each line contains two integers SMi and LMi, which means that the distance between the i-th town and the SMi town is LMi.

Output

Each case takes one line, print the shortest length that XiaoY reach seaside.

Sample Input

5 1 0 1 1 2 0 2 3 3 1 1 1 4 100 0 1 0 1

Sample Output

2

Source

2010 Asia Regional Harbin

 

题意:这道题输入的比较麻烦。第一行n代表有n个城市(标号0~n),然后有n行数据,这n行数据每行有两个数m,p,m代表i城市有m条路,p表示第i个城市是否连接海边,如果是0不连接,是1就连接海边。每个m,p,后接有m行数据,每行数据有两个字母s,l,s代表这条路连接的城市,l代表这条路的距离。最后问小y到海边的最短距离,注意小y住在0号城市。

 

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0xfffffff
int a[1000][1000];
int book[1000];
int dis[1000];
int v[1000];
int main()
{
    int n,m,i,j,k,t;
    while(scanf("%d",&n)!=EOF)
    {
        memset(book,0,sizeof(book));
        memset(v,0,sizeof(v));
        for(i=0; i<n; i++)
        {
            for(j=0; j<n; j++)
            {
                if(i==j)
                    a[i][j]=0;
                else
                    a[i][j]=inf;
            }
        }
        for(k=0; k<n; k++)
        {
            int x,y,t1,t2;
            scanf("%d %d",&x,&y);
            v[k]=y;
            for(i=0; i<x; i++)
            {
                scanf("%d %d",&t1,&t2);
                if(a[k][t1]>t2)
                a[k][t1]=t2;
            }
        }
        for(i=0; i<n; i++)
        {
            dis[i]=a[0][i];
        }
        for(i=0; i<n; i++)
        {
            int min1=inf;
            int v;
            for(j=0; j<n; j++)
            {
                if(book[j]==0&&dis[j]<min1)
                {
                    min1=dis[j];
                    v=j;
                }
            }
            book[v]=1;
            for(j=0; j<n; j++)
            {
                if(dis[j]>a[v][j]+dis[v])
                {
                    dis[j]=a[v][j]+dis[v];
                }
            }
        }
        int min1=inf;
        for(i=0; i<n; i++)
        {
            if(v[i])
            {
                if(dis[i]<min1)
                {
                    min1=dis[i];
                }
            }
        }
        printf("%d\n",min1);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值